RV Trip Planning Discussions

Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > Vintage RV's
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-20-2018, 12:35 PM   #1
Junior Member
 
nc77089's Avatar
 
Vintage RV Owners Club
Ford Super Duty Owner
Holiday Rambler Owners Club
Join Date: Jun 2018
Posts: 18
Ford F53 chassis starting issue

I have been having issues with starting my class A I keep having to use the house batteries to start it. I took the chassis battery in they see the battery still good but just needs recharging but even though they recharged it it's still not enough juice to start it up. at the same time when the started happening anytime I closed the driver's door there's a sound in the video there's this constant clicking sounds coming from the dash it's not the turn signal or the hazard lights. Some of my primary research suggests it could be some weird battery controller that goes between the house batteries that chassis batteries any help from anyone would be appreciated.
Attached Files
__________________

nc77089 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-20-2018, 12:44 PM   #2
Senior Member - DIYer
 
Waiter21's Avatar


 
Ford Super Duty Owner
Join Date: Nov 2014
Location: NW Ohio
Posts: 4,655
What year is this? What motor home is it?
__________________

__________________
1999 Fleetwood Southwind 35S (Ford F53 6.8L V10 4R100) - Toad 2003 Saturn Vue.
(www.1999Southwind.com)

It won't do MACH 2, but I can get a sandwich and take a pee.
Waiter21 is offline   Reply With Quote
Old 07-20-2018, 01:07 PM   #3
Junior Member
 
nc77089's Avatar
 
Vintage RV Owners Club
Ford Super Duty Owner
Holiday Rambler Owners Club
Join Date: Jun 2018
Posts: 18
i apologize its a 1999 Holiday Rambler Vacationer 32CG. After some more investigating its from the dash dimmer switch we go all the way up it turns on the overhead map light on clicking stops. But then the light on all the time would suck the battery dry. Turn the switch all the way down to off it starts clicking even with the door closed draining the battery.
nc77089 is offline   Reply With Quote
Old 07-21-2018, 09:13 AM   #4
Senior Member - DIYer
 
Waiter21's Avatar


 
Ford Super Duty Owner
Join Date: Nov 2014
Location: NW Ohio
Posts: 4,655
I assume the dash dimmer is part of the headlight switch assembly. Try unplugging the entire headlight switch assembly. When you hear the clicking, is the entry light (map light) coming on and off???

Here is a diagram of the interior lamps (This is the Ford chassis portion )

http://2001mirada.com/DOWNLOAD/E1I08901.pdf


..
__________________
1999 Fleetwood Southwind 35S (Ford F53 6.8L V10 4R100) - Toad 2003 Saturn Vue.
(www.1999Southwind.com)

It won't do MACH 2, but I can get a sandwich and take a pee.
Waiter21 is offline   Reply With Quote
Old 07-21-2018, 04:38 PM   #5
Junior Member
 
nc77089's Avatar
 
Vintage RV Owners Club
Ford Super Duty Owner
Holiday Rambler Owners Club
Join Date: Jun 2018
Posts: 18
After making my last post I went back out and when I pulled the lightbulb out of that overhead map light the clicking instantly stopped. so that issues been solved but it hasn't solved a larger issue with a possible battery problem trying to start the motorhome. I have pulled the chassis battery took it and have it tested at Advance Auto they said it only need a recharge I had them to a quick recharge on it got it back in the motorhome and still not enough power to start. To complicate that starting issue even more it has one of those magic start starter interrupters.
nc77089 is offline   Reply With Quote
Old 07-21-2018, 06:39 PM   #6
Senior Member - DIYer
 
Waiter21's Avatar


 
Ford Super Duty Owner
Join Date: Nov 2014
Location: NW Ohio
Posts: 4,655
Does it seem to be ranking at a normal speed??.. When did it start doing this??

verify the voltage at the starter. double check the grounds coming from the chassis battery.. You could have a bad starter.
__________________
1999 Fleetwood Southwind 35S (Ford F53 6.8L V10 4R100) - Toad 2003 Saturn Vue.
(www.1999Southwind.com)

It won't do MACH 2, but I can get a sandwich and take a pee.
Waiter21 is offline   Reply With Quote
Old 07-21-2018, 06:51 PM   #7
Senior Member
 
Ford Super Duty Owner
Join Date: Dec 2009
Location: Mcdonough, Ga.
Posts: 4,743
I do not believe you have a starter problem. Why would it not start on chassis batteries and will stert on house batteries? It sounds like you have a problem with the battery cables. Check and clean both hot and ground cables.
__________________
1998 Pace Arrow 35 ft. F53 Ford V10 2012 Honda Civic toad
32 years mechanic at Delta Air Lines 15 year motorhome service manager. 3 popups....2 travel trailers....5 motorhomes....loved them all.
ga traveler is offline   Reply With Quote
Old 07-22-2018, 07:46 PM   #8
Junior Member
 
nc77089's Avatar
 
Vintage RV Owners Club
Ford Super Duty Owner
Holiday Rambler Owners Club
Join Date: Jun 2018
Posts: 18
Quote:
Originally Posted by ga traveler View Post
I do not believe you have a starter problem. Why would it not start on chassis batteries and will stert on house batteries? It sounds like you have a problem with the battery cables. Check and clean both hot and ground cables.
That was it, it needs a new terminal connection. Started right up thanks for all the helpful input.
__________________

nc77089 is offline   Reply With Quote
Reply

Tags
chassis, f53, ford



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 Bounder on a 1999 Ford chassis starting issue billhuntz Ford Motorhome Chassis Forum 5 02-03-2015 01:38 PM
Another F53 Ford 460 not Starting Afubar Ford Motorhome Chassis Forum 36 06-04-2014 05:25 AM
Is a F53 chassis a 2012 Ford F-550 Super Duty Stripped Chassis joes2901 Ford Motorhome Chassis Forum 31 06-13-2012 06:01 AM
Bounder: HELP.. Starting issue with 1992 fleetwood Bounder f53 chassis. Pvreich Fleetwood Products Owner's Forum 5 03-10-2012 01:47 PM
Ford F53 engine starting 2007 LVJ58 Ford Motorhome Chassis Forum 3 01-09-2007 10:13 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:51 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.