Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > Vintage RV's
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-23-2005, 12:00 PM   #1
Junior Member
 
Join Date: Nov 2005
Posts: 12
Hi, I'm not sure if I should ask this on this forum but considering my Rv is a 1978 I thought you may be the best people to help. We recently bought this gem for 900.00. We are fixing it up but are having a small problem with the furnace and the generator. The furnace ignites and when the room reaches temperature the burner goes off but the fan doesn;t always switch off. It has run fine for the last two days. But occassionally this happens. Is there anything we can do to fix it?

And the generator we started once but not since.The automatic choke doesn't seem to be working and maybe the spark isn't strong enough. I would really like to get it running. We are trying to do this as cheaply as possible since we bought it on a whim.

Karen
__________________

__________________
Where are we going? And WHY am I in this handbasket?
cycledaze is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-23-2005, 12:00 PM   #2
Junior Member
 
Join Date: Nov 2005
Posts: 12
Hi, I'm not sure if I should ask this on this forum but considering my Rv is a 1978 I thought you may be the best people to help. We recently bought this gem for 900.00. We are fixing it up but are having a small problem with the furnace and the generator. The furnace ignites and when the room reaches temperature the burner goes off but the fan doesn;t always switch off. It has run fine for the last two days. But occassionally this happens. Is there anything we can do to fix it?

And the generator we started once but not since.The automatic choke doesn't seem to be working and maybe the spark isn't strong enough. I would really like to get it running. We are trying to do this as cheaply as possible since we bought it on a whim.

Karen
__________________

__________________
Where are we going? And WHY am I in this handbasket?
cycledaze is offline   Reply With Quote
Old 01-20-2006, 07:27 AM   #3
Senior Member
 
Dougmyers's Avatar
 
Join Date: Jan 2006
Location: TEXAS
Posts: 177
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by cycledaze:
Hi, I'm not sure if I should ask this on this forum but considering my Rv is a 1978 I thought you may be the best people to help. We recently bought this gem for 900.00. We are fixing it up but are having a small problem with the furnace and the generator. The furnace ignites and when the room reaches temperature the burner goes off but the fan doesn;t always switch off. It has run fine for the last two days. But occassionally this happens. Is there anything we can do to fix it?

And the generator we started once but not since.The automatic choke doesn't seem to be working and maybe the spark isn't strong enough. I would really like to get it running. We are trying to do this as cheaply as possible since we bought it on a whim.

Karen </div></BLOCKQUOTE>
================================
The furnace = two things come to mind for me.
1. The furnace runs until it cools down and temp sensor shuts the blower off.
2. A relay is sticking on the blower motor or the control board is failing.
--------------------------------
The Generator choke is electric and needs power to work, check for power at the choke when start button engaged. If it has power but not working you may need a new choke cylinoid.
__________________
Doug & Diane Myers

DFW, Texas
Dougmyers is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Furnace Problem Chilidip RV Systems & Appliances 9 05-12-2008 07:02 PM
Furnace problem Doug Sage Winnebago Industries Owner's Forum 10 11-23-2007 02:37 PM
Furnace Problem JJ Hamick Winnebago Industries Owner's Forum 6 10-22-2006 01:57 PM
Furnace problem in MH djohn MH-General Discussions & Problems 6 03-13-2005 06:22 PM
Furnace problem MH-General Discussions & Problems 13 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:39 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.