Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > Vintage RV's
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 07-25-2013, 03:31 PM   #1
Junior Member
Vintage RV Owners Club
Solo Rvers Club
Join Date: Jul 2013
Posts: 2
House lights dim/brighten/go out at times

My house lights are dimming/going out and then they come back on after a bit. House batteries are new and fully charged. Happens on either shore power or just on batteries. When it happens, if I press the battery state switch, it shows low and then nothing if all goes off. Any thoughts? Bad relay? BTW, I am installing a Best 4 stage charger/converter in it today, but that should not affect the issue in my mind anyway. Appreciate the help.


1985 Honey 26'
454 Chevy P30 frame, Onan 4KW
RetiredMark is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-25-2013, 07:24 PM   #2
Senior Member
MattC's Avatar
Join Date: Feb 2012
Location: SE Michigan
Posts: 459

You probably right and the new converter won't change anything.
- UNless One of the connections you change is the bad one.

Your symptoms exactly match a bad connection. It is OK for a while, then it heats up and when it does, the connection gets worse until so little power is passing the it gets to cool off and get better again.

These problem connections are most often at the battery posts, but they can be anywhere. Next time the lights start to dim, jump into the electric cabinet and touch every connection you can see. If any are hot, clean that one first.


A lifelong waterman and his bride going dry places for as long as the fuel money lasts.
MattC is offline   Reply With Quote
Old 07-26-2013, 04:32 PM   #3
Senior Member
BA-in-Mich's Avatar
Join Date: Apr 2011
Posts: 405
When I first bought my 1990 I had a similar problem it wound up being bad connections on the auto-reseting breakers under the hood that were mounted on the fire wall. Cleaned the connections it's been fine since.
1990 28' Georgie Boy, 454, 4bbl, Thorley Headers, Recurved Distributor, 8.75 mpg. RVM 76
BA-in-Mich is offline   Reply With Quote
Old 07-26-2013, 06:10 PM   #4
cronin069's Avatar
Join Date: Aug 2012
Location: carneys point New Jersey
Posts: 70
i had the same issue turned out vto be a broken neutral lug in power box got it fixed now all ok
cronin 1989 pace arrow 32k
cronin069 is offline   Reply With Quote
Old 07-26-2013, 06:54 PM   #5
Senior Member
BFlinn181's Avatar

Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 12,654
You need to check the connections in your converter/ fuse panel. If it's happening on shore power and battery alone, it sounds like the issue is a bad or loose connection near the fuse panel. There is no neutral lug on a 12 v system. I'd still do as has been suggested and feel for any warm cables or see if wiggling cables can create the flicker.

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is online now   Reply With Quote
Old 07-28-2013, 11:45 AM   #6
PeterS's Avatar
Join Date: Oct 2010
Location: Jersey Shore
Posts: 91
If you're changing a 1985 charger converter to a solid state step charge, That will probably fix it. I agree with everyone that it's a bad connection. My old battery boiler was a nightmare when I took it apart, now I have a quiet 3 step beauty.
1990/2014 30ft Gulf Stream Sun Clipper
and a couple of bikes
exit 100 NJ
PeterS is offline   Reply With Quote
Old 07-29-2013, 01:26 AM   #7
Junior Member
Vintage RV Owners Club
Solo Rvers Club
Join Date: Jul 2013
Posts: 2

All connections have been polished and tightened. A bit strange as when I tested things by loading the system a bit, the lights did their dim out/off/back on, etc, and then back on bright and have stayed that way. Am heading out later this morning for several days of dry camping while fishing so will get a good feel as to whether things are solved. Thanks for the replies, will do another update once back.

1985 Honey 26'
454 Chevy P30 frame, Onan 4KW
RetiredMark is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:25 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.