Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > Vintage RV's
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 08-27-2011, 11:53 AM   #1
Junior Member
Join Date: Aug 2011
Posts: 1
Ignition Problems

I have a Safari Renegade 1999 Harney Coach. Several months ago I turned it on, the motor did not turn on, but the stater turned and then would not stop --- I disconnected the battery to stop it. When I turn the ignition switch on - nothing happens - no dash lights etc. When I press the reserve battery switch, I can turn on the motor home via the ignition swithc and the dashlights come on.
Could this be a stuck relay switch from the ignition ??? The ignition switch works when the reserve battery button is pressed...so I figure the ignition switch is not faulty ...nor any
fuses.... any help would be greatly appreciated...


Plowharrow is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-27-2011, 12:01 PM   #2
Senior Member
tims52ford's Avatar
National RV Owners Club
Nor'easters Club
Join Date: Jul 2008
Location: Pawtucket, Rhode Island
Posts: 203
If your batteries were low when you tried to start it, the starter would stay engaged, caused by the starter solenoid contacts being fused together.
tims52ford is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
ignition problems bigeagle Class A Motorhome Discussions 13 01-27-2011 05:43 PM
wiper problems bobeb Newmar Owner's Forum 2 11-07-2010 08:33 PM
new rv problems rtree Winnebago Industries Owner's Forum 27 11-18-2008 06:29 PM
Ignition Problems Delbert21 Workhorse and Chevrolet Chassis Motorhome Forum 14 09-05-2008 07:18 AM
WH gas chassis ignition circuit problem WallyB Workhorse and Chevrolet Chassis Motorhome Forum 10 11-30-2005 11:20 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:46 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.