Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > Vintage RV's
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-29-2005, 05:19 AM   #1
Junior Member
 
Join Date: Jun 2005
Posts: 6
I have a 77 Winnebago Cheifton with a Kohler 4500 power plant. I recently had the thing up and running and it worked just fine. However I currently can not get her back up and running.

I have a full tank of gas and I can get gas down the fuel line to what appears to me to be a fuel pump to pump the the gas to the carb but if I pull the fuel line on the out side of the pump I get no gas to pump out thus no gas to the engine.

could this mean a bad fuel pump? Is that a fuel pump? There is a wire that comes out of what I believe to be the pump...could it be a electrical problem?

It is so frustrating since I just had the thing working fine
__________________

__________________
Scotts77Winnie is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-29-2005, 05:19 AM   #2
Junior Member
 
Join Date: Jun 2005
Posts: 6
I have a 77 Winnebago Cheifton with a Kohler 4500 power plant. I recently had the thing up and running and it worked just fine. However I currently can not get her back up and running.

I have a full tank of gas and I can get gas down the fuel line to what appears to me to be a fuel pump to pump the the gas to the carb but if I pull the fuel line on the out side of the pump I get no gas to pump out thus no gas to the engine.

could this mean a bad fuel pump? Is that a fuel pump? There is a wire that comes out of what I believe to be the pump...could it be a electrical problem?

It is so frustrating since I just had the thing working fine
__________________

__________________
Scotts77Winnie is offline   Reply With Quote
Old 06-29-2005, 08:41 AM   #3
Senior Member
 
Hoverbug's Avatar
 
Vintage RV Owners Club
Ford Super Duty Owner
Join Date: May 2001
Location: Klamath Falls, Oregon (The right side of the Cascades and home of Crater Lake)
Posts: 854
Scott, Start with a voltage check of the wire going to the fuel pump. Check also for a fuse. The Kohler genset on our former '78 Winny had a blown fuse; I don't remember the location though. Clean or change the fuel filter too. These gensets are not used much and build up tar in the fuel system. We never know how long these old girls have sat without being used.
__________________
Klamath Falls, Oregon:The Right Side Of The Cascades!
1990 Rexhall Airex 29I,Ford 460cid,Gear Vendor,Granning Tag Axel
'87 GMC Suburban 2500 W/454 CID
Hoverbug is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Journey power problems Ron Bush Winnebago Industries Owner's Forum 7 11-07-2008 06:29 PM
TV Power problems deelite Damon 6 10-13-2007 04:44 PM
Power problems rndsommer RV Systems & Appliances 6 10-04-2006 05:48 PM
Power problems machman72 MH-General Discussions & Problems 42 04-15-2006 08:08 AM
Power Plant Problems RV Systems & Appliances 2 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:15 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.