Go Back   iRV2 Forums > iRV2.com COMMUNITY FORUMS > Vintage RV's
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 09-15-2015, 04:38 AM   #1
Junior Member
Alle007's Avatar
Join Date: Aug 2015
Posts: 26
Starting Problem

After my rig sat for 2 weeks at a shop, it came back with a starting problem. It used to crank over, two pushes on the gas pedal and started right up. Now, when I turn the key, lights come on but does not crank over until i turn the key back and forth really fast, back and forth quickly. Then it starts to crank and eventually starts up, but seemingly almost not.
Does anyone know where this is coming from? or what it could be?
When I got my rig back the battery and two deep cycle marine batteries hooked in series where all dead and needed to be charged before attempting to start it.

1986 Allegro 7.4 Chevy 26ft Land Cruiser Fixer Upper
Alle007 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-15-2015, 05:04 AM   #2
Senior Member
Join Date: Jul 2014
Posts: 5,544
Classic sign of a sticky starter mounted solenoid.

First check all of the battery connections, positive and ground.

A test for a sticking solenoid, would be to have someone hold the key in start position and then tap the solenoid on the starter.
If it starts cranking, you need to pull It and change the solenoid or the whole starter.

twinboat is offline   Reply With Quote
Old 09-15-2015, 01:34 PM   #3
Junior Member
Alle007's Avatar
Join Date: Aug 2015
Posts: 26
Right on, thanks twinboat!
1986 Allegro 7.4 Chevy 26ft Land Cruiser Fixer Upper
Alle007 is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting Batteries Joedean Class A Motorhome Discussions 6 12-12-2014 01:21 PM
Trimark Paddle Latch Problem kpnestor Class A Motorhome Discussions 1 11-16-2014 08:15 PM
'06 Signature, Starting Problem Andrewmason Monaco Owner's Forum 48 11-15-2014 04:46 AM
Fleetwood RV starting problem Ford V10 TopherD Ford Motorhome Chassis Forum 12 06-25-2014 12:27 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:08 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.