Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > Pop Up, Tent Trailer and Teardrop Topics
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-12-2008, 07:09 AM   #1
Junior Member
 
Join Date: May 2008
Posts: 2
I have a 2007 21' Shamrock hybrid and the front bed leaks. It's been in the shop twice for this. We just got it back yesterday and we had a good rain last night so we checked it today and there is about a gallon of water laying on top of the tent. The seal has been replaced with a thicker one and it still doesn't seal good. Has anyone had this problem and do you know how to fix it? Our back bed is fine it's just the front. Please help, I love my camper and sure would hate to get rid of it.
__________________

__________________
brooks321 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-12-2008, 07:09 AM   #2
Junior Member
 
Join Date: May 2008
Posts: 2
I have a 2007 21' Shamrock hybrid and the front bed leaks. It's been in the shop twice for this. We just got it back yesterday and we had a good rain last night so we checked it today and there is about a gallon of water laying on top of the tent. The seal has been replaced with a thicker one and it still doesn't seal good. Has anyone had this problem and do you know how to fix it? Our back bed is fine it's just the front. Please help, I love my camper and sure would hate to get rid of it.
__________________

__________________
brooks321 is offline   Reply With Quote
Old 05-12-2008, 07:13 AM   #3
Senior Member
 
450Donn's Avatar
 
Join Date: Jun 2006
Location: Dallas,OR
Posts: 2,553
Since this is a really new unit and probably covered under warranty I would take it back and insist on a pressure test. That is the only way they are going to find the problem.
__________________
Don and Lorri
2007 Dodge 3500 dually
Resident Dummy.
450Donn is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why a Hybrid over Pop-Up Dejay Expandables, Hybrids, & Lightweights Discussion 35 04-09-2011 12:28 PM
Hybrid MH BigRedLancer Class A Motorhome Discussions 15 01-10-2008 05:41 AM
can a Hybrid Motorhome be far behind? rvcarpenter Winnebago Industries Owner's Forum 2 09-18-2007 08:37 AM
Leaking problems with Hybrid anyone else have problems? Barrie Expandables, Hybrids, & Lightweights Discussion 2 11-20-2005 09:08 AM
What about a Hybrid RV cubman iRV2.com General Discussion 7 10-15-2005 10:02 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.