Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > Pop Up, Tent Trailer and Teardrop Topics
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-01-2005, 04:06 PM   #1
Junior Member
 
Join Date: Jul 2005
Posts: 2
I have a JACO tent trailer "1995 Cardinal Series" with a Carson CP20 FKCR-2 converter-battery charger. When the trailer is plugged in the power supply works fine. However when I try to run off of the battery it does not work. Does anyone know how to contact converter manufacture for wiring info?

Thanks
__________________

__________________
JacoCamper is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-01-2005, 04:06 PM   #2
Junior Member
 
Join Date: Jul 2005
Posts: 2
I have a JACO tent trailer "1995 Cardinal Series" with a Carson CP20 FKCR-2 converter-battery charger. When the trailer is plugged in the power supply works fine. However when I try to run off of the battery it does not work. Does anyone know how to contact converter manufacture for wiring info?

Thanks
__________________

__________________
JacoCamper is offline   Reply With Quote
Old 07-02-2005, 11:04 AM   #3
Member
 
Medorg's Avatar
 
Join Date: Nov 2002
Location: Kansas City, MO USA
Posts: 82
I dont have a Jayco, but first thing to check is what do you have... When plugged into 110 volts you are getting 12 volts to work your lights, that proves your converter is working. When not connected to 110 volts == nothing == so that means your battery is not giving its 12 volts ... first and easiest is to check ALL fuses. Sometimes fuses work loose, and while they are not blown, they dont make contact in the holder. Next is the Battery connection. A small volt meter is the easiest. A jayco owner will help you on specifics.... welcome to the best Camper site on the net.
__________________
Medorg
Medorg is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery Power in Trailer Jodi Neal iRV2.com General Discussion 6 09-04-2008 03:33 AM
Intermittent electrical problem - no mirror power or camera power born2camp Workhorse and Chevrolet Chassis Motorhome Forum 5 07-14-2008 04:45 PM
Battery/Power supply problem and finding replacement owners manaul joebell Travel Trailer Discussion 5 08-19-2005 06:19 AM
house battery power loss Jack_Va MH-General Discussions & Problems 5 07-11-2005 11:00 AM
Battery Power in Trailer RV Systems & Appliances 6 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.