Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > Pop Up, Tent Trailer and Teardrop Topics
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-15-2005, 09:11 PM   #1
Junior Member
 
Popup Newfie's Avatar
 
Join Date: May 2003
Location: Marystown, Newfoundland, Canada
Posts: 6
Hi

First of all let me say that so far I have had a great camping season. However a couple of days before i ended my last trip,I started to experience water pump troubles. The water pump pumped water ok, but when I turned the faucet of the pump would continue to cut in and cut out every second,(like it was trying to build pressure back up) so I had to disconnect the power supply to the pump to prevent it from crapping out altogether. Can anyone tell me what might be the problem. Any suggestions would be greatly appreciated.
__________________

__________________
Popup Newfie

2004 Dodge Ram 1500 QC 4x4 Hemi
Popup Newfie is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-15-2005, 09:11 PM   #2
Junior Member
 
Popup Newfie's Avatar
 
Join Date: May 2003
Location: Marystown, Newfoundland, Canada
Posts: 6
Hi

First of all let me say that so far I have had a great camping season. However a couple of days before i ended my last trip,I started to experience water pump troubles. The water pump pumped water ok, but when I turned the faucet of the pump would continue to cut in and cut out every second,(like it was trying to build pressure back up) so I had to disconnect the power supply to the pump to prevent it from crapping out altogether. Can anyone tell me what might be the problem. Any suggestions would be greatly appreciated.
__________________

__________________
Popup Newfie

2004 Dodge Ram 1500 QC 4x4 Hemi
Popup Newfie is offline   Reply With Quote
Old 08-17-2005, 03:59 AM   #3
Senior Member
 
Winnebago Owners Club
Join Date: Dec 2003
Location: MN,USA
Posts: 651
Sounds like you either have a leaking faucet or other connection or you were very low on water. I suggest re-connecting the pump with water reasonably filled and see if the problem reoccures.
__________________
2004 Itasca Sunrise 36', Workhorse
2003 Suzuki XL7
Dsouthw524 is offline   Reply With Quote
Old 08-17-2005, 07:32 PM   #4
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 26,792
Do you have a valve that you open to fill your water tank , if left open with city water connected pump will operate . Close valve will stop pump from operating. "007"
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 08-18-2005, 04:55 PM   #5
Member
 
ThunderRock's Avatar
 
Join Date: Nov 2002
Location: Ferndale, MI -USA
Posts: 53
In addition to those suggestions, maybe just a simple filter cleaning would do the trick.
__________________
Ken & Ruth

'05 Fleetwood Mallard 180CK
ThunderRock is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water Pump Help Tcloud7 Winnebago Industries Owner's Forum 4 10-25-2008 07:37 AM
Water Pump CTSibley 5th Wheel Discussion 7 05-08-2008 04:15 PM
Water Pump Rick Coleman Alpine Coach Owner's Forum 11 03-12-2008 03:58 PM
water pump farmer63 Winnebago Industries Owner's Forum 23 11-09-2007 09:06 AM
House pump water hammering and spurts of cold water Frankie MH-General Discussions & Problems 2 04-18-2006 01:05 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:23 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.