Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-15-2007, 06:15 AM   #1
Member
 
Nick and Sheila's Avatar
 
Join Date: Oct 2004
Location: NE Fla
Posts: 48
Strange thing happened last night. We have a 2005 KSDP 3910, we are full-timers and hooked to shore power. We had lights on in the coach, all the overhead lights and the reading lights over both couches and I noticed a flicking in the lights. So I checked the 12vdc on the intellitec panel it indicated the 12v dropping from 13.7 to 12.4 and stayed there. I pushed the Battery push button on the tank level panel and it show 3 bars/lights. I started turning off lights and the voltage came backup to 13.7 that it normally is. I have (2) 6vdc batteries that are less than 2 month old, checked water level this weekend it was fine. I have a 600w inverter, but I checked it and it was not operating. So what do you think this issue was/is?
__________________

__________________
The Nick and Sheila Club, same two members for 30 years.

05 Kountry Star 3910
Nick and Sheila is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-15-2007, 06:15 AM   #2
Member
 
Nick and Sheila's Avatar
 
Join Date: Oct 2004
Location: NE Fla
Posts: 48
Strange thing happened last night. We have a 2005 KSDP 3910, we are full-timers and hooked to shore power. We had lights on in the coach, all the overhead lights and the reading lights over both couches and I noticed a flicking in the lights. So I checked the 12vdc on the intellitec panel it indicated the 12v dropping from 13.7 to 12.4 and stayed there. I pushed the Battery push button on the tank level panel and it show 3 bars/lights. I started turning off lights and the voltage came backup to 13.7 that it normally is. I have (2) 6vdc batteries that are less than 2 month old, checked water level this weekend it was fine. I have a 600w inverter, but I checked it and it was not operating. So what do you think this issue was/is?
__________________

__________________
The Nick and Sheila Club, same two members for 30 years.

05 Kountry Star 3910
Nick and Sheila is offline   Reply With Quote
Old 03-15-2007, 06:39 AM   #3
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 26,727
Sounds like your losing the charge from converter for batteries. If the power in CG dropped would cause your batteries to supply the voltage for lights which would be less than converter output. Did you have a TV on at the time? The converter could still have a problem.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is online now   Reply With Quote
Old 03-15-2007, 06:43 AM   #4
Member
 
Nick and Sheila's Avatar
 
Join Date: Oct 2004
Location: NE Fla
Posts: 48
When the lights started to flicker I checked the 110 vac was steady, and I did have the TV on at the time. What would cause me to lose the charge to the batteries from the converter?
__________________
The Nick and Sheila Club, same two members for 30 years.

05 Kountry Star 3910
Nick and Sheila is offline   Reply With Quote
Old 03-15-2007, 07:21 AM   #5
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 26,727
Possibly a loose conection, grounds for a starter you have a ground wire heavy bare copper to frame of chassis near converter, than one from your batteries to frame near their location. The converter although nearly new could have some thing going wrong if you could put a meter accross output for 12v to monitor it may indicate something. Also check connections for 12v off your converter.
Are you still experiencing drop offs?
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is online now   Reply With Quote
Old 03-16-2007, 06:50 AM   #6
Senior Member
 
Join Date: Oct 2002
Location: Traveling in the East
Posts: 533
Also check terminal connections on batteries if they are clean and not corroded.

Joe
__________________

full-timer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
converter fan not operating/12VDC circuit problem Ray,IN RV Systems & Appliances 5 07-27-2007 12:19 PM
12VDC outlet unfinished91 Excel Owner's Forum 5 12-20-2006 04:31 PM
Converting a120 AC Stereo to 12VDC Long Haul Ken RV Systems & Appliances 3 05-16-2006 07:17 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.