Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-24-2015, 10:18 AM   #15
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 18,073
Lots of obscure problems related here, but I would check the simple things first. The fact that the engine cranks fine but the dash gauges are out is a major clue, so I would first look at the ignition switch. It closes a relay that provides power to the dash and associated stuff.

What happens when you turn the key on but not to the Start position? Any lights at all on the dash? And sounds? Gauges?
__________________

__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-25-2015, 09:41 PM   #16
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 14,970
Gas? Diesel ? Class A ? Class C ?

Gauges not operating , first thing is to check all the chassis fuses.

After that , we need more info to be of any real help.
__________________

__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 10-26-2015, 06:45 PM   #17
Member
 
Join Date: Nov 2011
Location: Layton, Utah
Posts: 69
I think to be of any real help you need a wiring diagram. The 12 volt line that applies 12 v to the ignition switch is also the 12 v line for the starter relay through the start position of the key switch,( which you are getting ) and is also the same line for the run position of the ignition switch which gets your motor running. If your fuses are good and I would double check them with an ohm meter, I would suspect the ignition switch or a wire from it.
__________________
2000 Damon is offline   Reply With Quote
Old 10-27-2015, 09:23 AM   #18
Member
 
Winnebago Owners Club
Join Date: Mar 2015
Posts: 37
my 1998 chev

Thank you I will pass this onto the shop who has my rv....Thanks again
Boyd Johnson

bjohn10387@aol.com
__________________
boydj1 is offline   Reply With Quote
Old 10-30-2015, 03:58 AM   #19
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
Have you actually checked for power feeding the dash fuse panel? I suspect you have an issue ahead of that panel. Start at the battery bank and check for power and good ground connections and down stream to disconnects, circuit breakers and relays for an open connection. There are more relay behind the circuit breaker panel face. Good luck and keep us posted.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 10-31-2015, 06:55 AM   #20
Senior Member
 
Join Date: Dec 2014
Posts: 182
Back when I used to work on vehicles there was what is called a fusible link, it is built into the wire coming from the starter that feeds most of the electrical power to the chassis, it would probably be identified as a yellow button connector. Don't know if these would still exist in your 1998.

Just a thought, hope you find your problem.
__________________
Jerry & CP (copilot) Joyce
2000 Coachmen Mirada 340 MBS ( Pretty Penny )
Getting lost every chance we get.
pop-sicle is offline   Reply With Quote
Old 11-06-2015, 06:19 PM   #21
Member
 
Winnebago Owners Club
Join Date: Mar 2015
Posts: 37
454 Chev engine

I would like to thank all of you for your reply. The problem was the "ignition switch connection block located at the bottom of the steering column.
__________________
boydj1 is offline   Reply With Quote
Old 11-07-2015, 01:53 AM   #22
Senior Member
 
DAN L's Avatar
 
Winnebago Owners Club
Workhorse Chassis Owner
Join Date: Sep 2007
Posts: 2,898
boydj1
thx for posting the fix. many do not.
__________________

__________________
01 WINNEBAGO 35U W20.8.1L SW Wa, Hi. Good Sam, SKP. AMSOIL fluids. BANKS ecm program. SCAN GAUGE II w/ Ally temp. 2 LIFELINE GPL-6CT AGM Batts on their sides. TST tptts. K&N panel air filter. AERO mufflers. TAYLOR plug wires. ULTRA POWER track bar. KONI fsd shocks, toad '14 smart car
DAN L is offline   Reply With Quote
Reply

Tags
454, engine, gas, winnebago



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1973 Winnebago Brave wont start kenpokrazy Class C Motorhome Discussions 3 11-25-2014 05:59 PM
Winnebago Sightseer tire problem Ferrar Winnebago Industries Owner's Forum 6 08-20-2014 12:00 AM
Magnum Auto Gen Start problem? Miramar2014 Thor Industries Owner's Forum 2 04-13-2014 09:11 AM
Back up camera problem - Winnebago n5pht Class C Motorhome Discussions 3 03-23-2014 08:08 AM
My 1998 Cummin 5.9L won't start SuperDad Cummins Engines 18 10-08-2013 02:42 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.