Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-22-2013, 10:19 AM   #1
Member
 
rdurham1954's Avatar


 
Newmar Owners Club
Spartan Chassis
Join Date: Nov 2011
Location: Colleyville Texas
Posts: 30
2013 Baystar 3209 Equalizer Levelers Dont Deploy

I can get the keypad to turn on, but all I get is steady red lights. No alarms, but when I try to Auto Level I get the deny alarm. I also get it when I try to lower one or another individually. Checked the fluid level and topped it off. Still doesn't deploy. Anyone with an Equalizer system that knows how to reset the system or try anything else to get them to move?
__________________

__________________
rdurham1954 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-22-2013, 05:25 PM   #2
Senior Member
 
Fred and Bonnie's Avatar
 
Workhorse Chassis Owner
Join Date: Jan 2002
Location: Pacific Northwest or SoCal
Posts: 2,838
Send a message via ICQ to Fred and Bonnie
Just thoughts, sounds like the system is not sensing the parking brake set or transmission in park.

fred
__________________

__________________
Fred and Bonnie
2005 Dolphin LX 6375
Abby, Ruffles & Scarlett, "The Cats"
Fred and Bonnie is online now   Reply With Quote
Old 07-23-2013, 11:03 AM   #3
Senior Member
 
mgscott4's Avatar
 
Workhorse Chassis Owner
Join Date: May 2009
Location: Kansas City, MO./Pollock, LA.
Posts: 1,549
Press the retract button. Once the retract cycle is complete they will work.
__________________
06 Hurricane 34FT WH W20 Chassis 8.1L 132K, Steersafe, Koni Shocks, DIY Trac Bar, Tri-Metric 2025RV Battery Monitor, 4-6V Batteries, Scan Gauge 2, Crossfires, 735W Solar Morningstar MPPT-60, WG T4 In-Motion Sat, XM Radio, 07 Chevy Malibu Maxx Toad, Falcon 2, Brake Buddy, Escapee
mgscott4 is offline   Reply With Quote
Old 07-23-2013, 12:03 PM   #4
Member
 
rdurham1954's Avatar


 
Newmar Owners Club
Spartan Chassis
Join Date: Nov 2011
Location: Colleyville Texas
Posts: 30
Tried that but no joy. Tech support says it may be a bad motor or panel.
__________________
rdurham1954 is offline   Reply With Quote
Old 07-24-2013, 07:51 AM   #5
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 26,748
Make sure motor mount bolts are tight for good chassis ground connection also check the ground cable from battery to chassis frame for good clean tight connection.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Reply

Tags
levelers



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Low point drain for 2013 Hurricane 32A Bill206 Thor Industries Owner's Forum 15 03-01-2015 12:05 PM
Bay Star owners? Camper Ken Newmar Owner's Forum 66 08-17-2014 09:28 PM
Kwikee Levelers / Dexron III Question RTegarini Winnebago Industries Owner's Forum 5 07-09-2013 07:44 AM
WIT Rally Schedule Offers Multitude of Fun Activities for 2013. DriVer RV Industry Press 3 06-22-2013 09:38 PM
Big Foot Levelers Not Responding - Happy Ending jnp_macklin Class A Motorhome Discussions 2 06-03-2013 10:03 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:38 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.