Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 06-30-2009, 04:53 PM   #1
Junior Member
art(alamoc)'s Avatar
Join Date: Jun 2009
Posts: 7
4000 microlite Onan not starting

1999 coachman mirada, the generator has not started since 2007, I put a new fuel pump in 2007 when it would not start but no luck. Now my daughter wants to use it for a week trip, when I push the start button outside on the unit it cranks fast and I have sprayed starter fluid but as soon as I release the button it dies. The fuse switch has two positions and it is pointed to the 30 amp position to the right and I have put it to the left and still no start. I have fuel at the hose where it enters the carburator. What else can I check?

art(alamoc) is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-30-2009, 07:14 PM   #2
Moderator Emeritus
TXiceman's Avatar

Vintage RV Owners Club
Texas Boomers Club
Oklahoma Boomers Club
Ford Super Duty Owner
Join Date: Aug 2000
Location: Full Time, TX Home Base
Posts: 17,139
Blog Entries: 21
Make sure the run circuit for the ignition is staying energized once the start switch is released. Also, most generators will not operate with less than 1/4 of a fuel tank on the chassis tank.


Amateur Radio Operator (KE5DFR)|Full-Time! - 2012 6.7L Ford Crew Cab Dually -2013 HitchHiker Champagne 38RLRSB - Travel with one Standard Schnauzer and one small Timneh African Gray Parrot
TXiceman is offline   Reply With Quote
Old 06-30-2009, 07:22 PM   #3
Junior Member
art(alamoc)'s Avatar
Join Date: Jun 2009
Posts: 7
I would like to add that as I hold down the start button without letting up on the button on the generator, it starts for about 5 seconds then dies and restarts it's self on and on. I can play with the throttle linkage and keep it running for about 15 seconds, it seems like it runs out of gas. could the gas be to old, the chev engine runs OK with the same gas, the gas is over a year old.
art(alamoc) is offline   Reply With Quote
Old 06-30-2009, 07:25 PM   #4
Junior Member
art(alamoc)'s Avatar
Join Date: Jun 2009
Posts: 7
How do you check the run circuit for the ignition, where is it located?
art(alamoc) is offline   Reply With Quote
Old 07-15-2009, 08:27 PM   #5
Join Date: Jun 2009
Posts: 54
Check the fuel line from fuel pump to main tank. I had that trouble and found two small cuts in the line had rubbed against the frame. the hole was not big enough for gas to run out but the fuel pump was just sucking air, replaced about three foot of the line and it runs great now. if that is not it would check the carburetor if you have not run it regular it is probably gummed up.
wcombs34 is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan MicroQuiet 4000 generator questions JC Andrews RV Systems & Appliances 10 06-17-2013 06:56 PM
Removing carburator off a 4000 onan art(alamoc) MH-General Discussions & Problems 2 07-05-2009 08:56 AM
Onan Genset 5500 gas HGJAB model not starting always udbe2 RV Systems & Appliances 9 05-19-2009 06:55 PM
Onan Starting Issues LazyDog Winnebago Industries Owner's Forum 31 05-20-2007 02:33 AM
onan microlite 4000 running problem fanblade MH-General Discussions & Problems 8 07-09-2006 01:08 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:48 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.