Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-09-2007, 02:13 PM   #1
Senior Member
 
BBBEEBOP's Avatar
 
Join Date: May 2003
Location: Sayre,PA USA
Posts: 321
Our Weather Pro awning had been working perfectly, until the other day when the wind sensor unit closed the awning automatically. (like it is supposed to do) but now the awning won't go out again. I can hear the motor turning from the ground but the awning doesn't move. Any suggestions?
__________________

__________________
Bob, Laurie & Missy
2013 Itasca Cambria 27K
BBBEEBOP is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-09-2007, 02:13 PM   #2
Senior Member
 
BBBEEBOP's Avatar
 
Join Date: May 2003
Location: Sayre,PA USA
Posts: 321
Our Weather Pro awning had been working perfectly, until the other day when the wind sensor unit closed the awning automatically. (like it is supposed to do) but now the awning won't go out again. I can hear the motor turning from the ground but the awning doesn't move. Any suggestions?
__________________

__________________
Bob, Laurie & Missy
2013 Itasca Cambria 27K
BBBEEBOP is offline   Reply With Quote
Old 09-09-2007, 02:37 PM   #3
Senior Member
 
John_Canfield's Avatar
 
Join Date: Jan 2005
Location: Back at the ranch
Posts: 2,538
Sounds like there is a mechanical problem at the motor somewhere. You might want to have a service tech dig into the problem.
__________________
--John

2005 Horizon 40AD, 2005 Jeep Liberty CRD
John_Canfield is offline   Reply With Quote
Old 09-09-2007, 04:57 PM   #4
Member
 
Freightliner Owners Club
Join Date: Sep 2004
Location: Portland, Oregon
Posts: 47
I recently had the same problem on my 2005 Journey. The dealer determined that the control module was shot and replaced it. It works fine now. There is a three year warranty.

Daniel C. Ellis
2005 Journey 39F
Portland, Oregon
__________________
dcellisesq is offline   Reply With Quote
Old 09-10-2007, 11:24 AM   #5
Member
 
dveasey's Avatar
 
Tiffin Owners Club
Workhorse Chassis Owner
Join Date: Aug 2006
Posts: 79
Motor sounds fine? then, Look for the tooth-gear on the drive shaft of the motor. Recent post on tiffinrvnetwork forum had found that this gear had slide out-of-place. Simple fix to move it back into position. Secure with a small dab of silicone caulk.
__________________
2004 Tiffin 34XB,Workhorse.22K,8.1L,Gas
Saturn SL
dveasey is offline   Reply With Quote
Old 09-19-2007, 08:48 AM   #6
Senior Member
 
BBBEEBOP's Avatar
 
Join Date: May 2003
Location: Sayre,PA USA
Posts: 321
Well, the awning is finally fixed. After many calls to Dometic by my dealer and lots of different opinions, a new motor was installed.
Dometic would not cover the repair as I am the second owner of the coach. However, my extended EasyCare warranty covered part of it.
Let's hope this one lasts longer than the original.
__________________
Bob, Laurie & Missy
2013 Itasca Cambria 27K
BBBEEBOP is offline   Reply With Quote
Old 09-19-2007, 04:55 PM   #7
Senior Member
 
Winnebago Owners Club
Join Date: Apr 2000
Location: Waynesboro,PA USA
Posts: 644
Good Luck we have had 2 motors, 1 control box and 1 new sensor. Ours is actually working but who knows how long. lol
__________________

__________________
Downsized Winnebago C, 24 V /08 Saturn Vue/2014 Town and Country Van/03 Goldwing (Big Red)Recently triked Roadsmith kit
Beabop is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A&E Awning Weather Pro Shaun and Amy Newmar Owner's Forum 16 07-06-2008 08:10 PM
Weather Pro Awning Minisprint MH-General Discussions & Problems 12 07-23-2006 12:27 PM
A&E Weather Pro Awning Winnebago Industries Owner's Forum 6 12-31-1969 07:00 PM
weather pro awning RV Systems & Appliances 22 12-31-1969 07:00 PM
A&E Awning Weather Pro MH-General Discussions & Problems 16 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:28 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.