Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 05-08-2011, 03:01 PM   #1
Junior Member
Vcjp03's Avatar
Join Date: Mar 2011
Posts: 14
A/C problem

This afternoon i was working inside my MH after triyng all the lights i start the A/C at the same time my wife close one of the light and the A/C stop since everytime i play with the thermostat the only thing happening is a tic,tic inside the A/C anyone got a idea what's the issue.

Thanks Jp

Vcjp03 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-08-2011, 03:08 PM   #2
Senior Member
OneRVer's Avatar
Triple E Owners Club
Join Date: Aug 2010
Location: Pacific Northwest
Posts: 723
Have you chacked your A/C breaker, 110 VAC. I believe you have a 12 volt relay that starts your A/C. That might be the ticking sound. Do you have 12 VDC at the thermostat? Now I don't know much about the A/C but this will give you a starting point to look at until someone with the knowledge replys.

1997 Triple E Empress, Freightliner Chassis, CAT 3126 w/ 275 horse's.
MD 3600 Tranny, 2011 Ford Escape Hybrid w/Blue Ox tow bar and Roadmaster Base Plate.
Amsoil Synthetic Oil only for my baby.
OneRVer is offline   Reply With Quote
Old 05-09-2011, 08:09 AM   #3
Senior Member
AFChap's Avatar
Winnebago Owners Club
Spartan Chassis
Join Date: Aug 2002
Location: ...hopefully on the road!
Posts: 4,433
Many (most?) ac inits will not start up again immediately after stopping to protect the compressor. Mine has an apx 2 min delay before it will re-start. Even though you can hear the t'stat click on.
Paul (KE5LXU) ...was fulltimin', now parttimin'
'03 Winnebago UA 40e / '05 Honda Odyssey toad
AFChap is offline   Reply With Quote
Old 05-09-2011, 03:19 PM   #4
Senior Member
doc's Avatar
Appalachian Campers
Join Date: Sep 2002
Location: Dixie !! (north Georgia) USA
Posts: 2,839
I cannot say if it will work for your coach, but I can tell you what a tech told us to do in a similar situation - and it worked. Turn off all sources of power to the coach ( I unplugged ours from the post) and turn the batteries off as well. He said to wait 10-12 minutes and the a/c would re-set itself. After the specified time, I repowered the system and turned the A/C back on and it worked just like it was supposed to. I believe they are Carrier remote control thermostat types.
Hope it works for you.
doc is offline   Reply With Quote
Old 05-09-2011, 06:00 PM   #5
Junior Member
Vcjp03's Avatar
Join Date: Mar 2011
Posts: 14
Thanks guy's i found it try what Doc said and it work great trick thanks again
Vcjp03 is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Yamaha EF2400iS Generator don’t run 13,500 AC santurinos Travel Trailer Discussion 11 08-20-2012 01:44 PM
A/C heater valve problem TXredfish MH-General Discussions & Problems 3 09-04-2010 11:15 AM
Kit Camper Projects - Project #7, Installing a Household A/C Unit RedneckExpress Vintage RV's 1 02-03-2008 08:18 PM
A/C Fan problem Tuke 5th Wheel Discussion 6 08-14-2006 04:38 PM
Dash A/C Repair - Need some sage advice chasfm11 MH-General Discussions & Problems 11 11-06-2005 01:18 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:14 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.