Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-21-2008, 08:19 AM   #1
Junior Member
 
Join Date: Jun 2008
Posts: 18
I have an Alpine (2003) and have encountered a problem where as the horn and wipers do not consistently work (sometimes the horn sticks and continues to blow, and when turning off the windshield wiper the horn starts to blow) also the cruise control does not work now.
I understand that Alpine went out of business, and am looking for someone who might refer me to a dealer in the southwest Chicago area for repairs and/or any other thoughts around a needed fix.
Thanks,
Rexx
__________________

__________________
Rexx is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-21-2008, 08:19 AM   #2
Junior Member
 
Join Date: Jun 2008
Posts: 18
I have an Alpine (2003) and have encountered a problem where as the horn and wipers do not consistently work (sometimes the horn sticks and continues to blow, and when turning off the windshield wiper the horn starts to blow) also the cruise control does not work now.
I understand that Alpine went out of business, and am looking for someone who might refer me to a dealer in the southwest Chicago area for repairs and/or any other thoughts around a needed fix.
Thanks,
Rexx
__________________
Rexx is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 DOLPHIN LX BRAKE CONTROLER WIRE HARNESS trophylite National RV Owner's Forum 2 09-01-2008 10:23 AM
Docking Lights? (or wire harness) On A Diplomat kaisooba Monaco Owner's Forum 4 07-14-2008 04:22 PM
Tilt steering wheel problem etc. Forest Grump Ford Motorhome Chassis Forum 1 07-09-2008 01:19 PM
Alpine Coach Steering Problem cajunjohn Alpine Coach Owner's Forum 14 05-19-2008 09:35 PM
Spartan Chassis wire harness recall dlhaynes Newmar Owner's Forum 4 04-23-2006 03:36 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:38 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.