Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-24-2011, 09:16 PM   #1
Junior Member
 
derfgrly's Avatar
 
Join Date: Jan 2011
Posts: 6
annunciator problems

we bought a used 1999 georgie boy cruise master with a 5.9 cummins several months ago. The engine batteries went dead and my wife had them replaced. Since that time the annunciator panel lights flash off and on in a rotating sequence until the batteries go dead. Spoke with a freightliner tech and he suggested unplugging the VDC(vehicle data computer) and replugging in, Unplugging stopped the sequencing but upon replugging it started back up. My wife is on assignment with the MH and I only get there occasionally. Ideas?
__________________

__________________
derfgrly is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-25-2011, 04:26 AM   #2
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
Make sure the battery cables are all back on the batteries properly. If that does not correct the problem, then take it to a Freightliner shop for diagnosis and repair.
__________________

__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 02-25-2011, 09:04 AM   #3
Senior Member
 
AFChap's Avatar
 
Winnebago Owners Club
Spartan Chassis
Join Date: Aug 2002
Location: ...hopefully on the road!
Posts: 4,719
Yep, sounds like the panel is trying to tell you something ...and the batteries apparently are not charging ...batteries hooked up wrong sounds like a very likely cause.
__________________
Paul (KE5LXU) ...was fulltimin', now parttimin'
'03 Winnebago UA 40e / '05 Honda Odyssey toad
AFChap is offline   Reply With Quote
Old 03-06-2011, 11:56 AM   #4
Junior Member
 
derfgrly's Avatar
 
Join Date: Jan 2011
Posts: 6
Thumbs up

Thanks for your input... just had the opportunity yesterday to check battery cables. Not terribly bad but it does appear the cable ends were not cleaned when they replaced the batteries. Cleaned all cable ends and it seems to have solved the problem! Thanks
__________________
derfgrly is offline   Reply With Quote
Old 03-06-2011, 05:18 PM   #5
Community Administrator
 
JohnRR's Avatar


 
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Sep 2010
Location: Marquette, Michigan "Da UP"
Posts: 16,943
Thank you for the update.
__________________
John & Cathy R.
06 Pace Arrow 38L W24
08 14 Lincoln MKX AWD
See My RV Upgrades
JohnRR is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.