Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-02-2012, 05:35 PM   #1
Senior Member
 
Jchet's Avatar
 
Join Date: Apr 2012
Location: Clermont fl
Posts: 182
Another genset question

I'm wanting to change the air filter since the one on this unit is probably the one it came with in 1995. It appears to be a large canister filter towards the back of the genset.

Anyone know a air filter number on these old school 7.5 kw gensets?
__________________

__________________
J.Chet USAF LTC Retired
Teddy & Bella (Soft Coated Wheaten's)
Jchet is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-02-2012, 06:11 PM   #2
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,251
Need more information. Make, model of genset? Try googling the information, you might find a PDF copy of the manual.
__________________

__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Old 10-02-2012, 06:53 PM   #3
Senior Member
 
Join Date: May 2009
Posts: 463
Mine is on the front of the gen set near the bottom.
__________________
Doug and Cassi
'05 Itasca Meridian 36G
'99 Jeep Wrangler
OldChief7155 is offline   Reply With Quote
Old 10-03-2012, 05:57 PM   #4
Senior Member
 
Jchet's Avatar
 
Join Date: Apr 2012
Location: Clermont fl
Posts: 182
I took it to the Cummings facility today, after changing the fuel filter I couldn't get the genset to start. I scheduled them to change the air filter and get it fired.
__________________
J.Chet USAF LTC Retired
Teddy & Bella (Soft Coated Wheaten's)
Jchet is offline   Reply With Quote
Old 10-03-2012, 06:44 PM   #5
Senior Member
 
clyon51's Avatar
 
Monaco Owners Club
Join Date: Mar 2012
Location: Arizona West RV Park, Yuma, Az
Posts: 4,117
Quote:
Originally Posted by Jchet
I took it to the Cummings facility today, after changing the fuel filter I couldn't get the genset to start. I scheduled them to change the air filter and get it fired.
I'm confused. Why did you take it to Cummins in the first place? If it wouldn't start, why did you assume it was the fuel filter? Why do you assume it is the air filter now? There are many, many things that can cause a generator not to start. The air filter is the last thing I would suspect.

If you want to give us some history and specifics on the make/model, and exact problems, I'm sure someone can give you specific things to ckeck. Otherwise, you might as take it back and have Cummins figure it out and charge you accordingly.
__________________
John & Clare Lyon
2007 43.5' Monaco Dynasty Palace III (All Electric)
Towd: 2011 Chevy Equinox
clyon51 is offline   Reply With Quote
Old 10-03-2012, 07:02 PM   #6
Senior Member
 
Jchet's Avatar
 
Join Date: Apr 2012
Location: Clermont fl
Posts: 182
It's a 7.5 DKD model.

It always has been running, I changed the fuel filter because this genset is the original with the 1995 coach. It only has 530 hrs but the fuel filter was the original filter that came on the genset. I suspect the air filter is also. I didn't change the oil and filters because it wasn't running I did it because I want it to continue to run. After changing the fuel filter I was unable to get it to start today.

I was taking the coach to Cummings to handle the coolant filter change and decided to have them handle the air filter and starting issue on the genset while there out of convenience. I have a lot to get handled in the office Thursday so I can leave out of town for 3 days in the MH. I lack time tomorrow to spend the day out of my office and at my warehouse dealing with these issues. Sometimes I have to hire an expert out of lack of knowledge and sometimes because of a lack of time. This is a time issue to gain knowledge.
__________________
J.Chet USAF LTC Retired
Teddy & Bella (Soft Coated Wheaten's)
Jchet is offline   Reply With Quote
Old 10-03-2012, 07:27 PM   #7
Senior Member
 
steved44's Avatar
 
Join Date: Nov 2007
Posts: 189
I would suspect you got air in the system. Hold down on the off button on the genset for about a minute and that will purge any air from the system. Then try to start it again. If it's a tiffin, they used to put a second fuel filter up on the frame rail on the drivers side behind the generator. This filter is a wix 33031 which was used on older model dodge vehicles. Just some thoughts. Steve
__________________
steved44 is offline   Reply With Quote
Old 10-04-2012, 08:51 AM   #8
Senior Member
 
clyon51's Avatar
 
Monaco Owners Club
Join Date: Mar 2012
Location: Arizona West RV Park, Yuma, Az
Posts: 4,117
Jchet, all makes perfect sense now, sorry for my confusion. I certainly understand time constraints, I had plenty when I was working. Have a safe and uneventful trip!
__________________
John & Clare Lyon
2007 43.5' Monaco Dynasty Palace III (All Electric)
Towd: 2011 Chevy Equinox
clyon51 is offline   Reply With Quote
Old 10-04-2012, 07:45 PM   #9
Senior Member
 
Jchet's Avatar
 
Join Date: Apr 2012
Location: Clermont fl
Posts: 182
Quote:
Originally Posted by clyon51 View Post
Jchet, all makes perfect sense now, sorry for my confusion. I certainly understand time constraints, I had plenty when I was working. Have a safe and uneventful trip!
No problem, besides it turns out the reason for the no start has to do with the fuel pump had gone out so a new one was ordered and being installed in the AM.
__________________

__________________
J.Chet USAF LTC Retired
Teddy & Bella (Soft Coated Wheaten's)
Jchet is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:16 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.