Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-01-2010, 02:49 PM   #1
Senior Member
 
Workhorse Chassis Owner
Join Date: Apr 2010
Location: Trenton NE
Posts: 244
Another little problem... auto vent

The motor on "fantastic fan vent", keeps running even when switch is turned off. Only way I can stop it is take out the fuse. Is this a circuit biard problem or ??? Thanks for any help. Alleyman. 2004 Dolphin
__________________

__________________
Alleyman is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-01-2010, 03:43 PM   #2
Senior Member
 
RVThere's Avatar
 
Freightliner Owners Club
Join Date: Aug 2008
Location: Florida Keys
Posts: 2,163
Sounds like a bad switch problem. Some 'fantastics' have a mechanism to switch off when the cover is down. Will it run even when the cover is down?
__________________

__________________
Tom and Katharine
'07 Winnebago Tour 40TD, 400hp Cummins
'17 Winnebago View 24V, '02 R-Vision B+
RVing for 19 years & 150,000+ miles
RVThere is offline   Reply With Quote
Old 06-01-2010, 04:14 PM   #3
Senior Member
 
Workhorse Chassis Owner
Join Date: Apr 2010
Location: Trenton NE
Posts: 244
Yes, it keeps running even when I turn it to the off position. Must be the board. Thanks.
__________________
Alleyman is offline   Reply With Quote
Old 06-01-2010, 04:39 PM   #4
Senior Member
 
bigskymt's Avatar
 
Newmar Owners Club
Join Date: Apr 2010
Posts: 462
Did you try to call the factory? They have excellent tech support and really stand behind their product. I believe the number is 800.521.0298
__________________
bigskymt is offline   Reply With Quote
Old 06-01-2010, 07:07 PM   #5
Senior Member
 
Workhorse Chassis Owner
Join Date: Apr 2010
Location: Trenton NE
Posts: 244
Thanks very much, Bigskymt. I will give them a call tomorrow.
__________________
Alleyman is offline   Reply With Quote
Old 06-01-2010, 07:15 PM   #6
Senior Member
 
Ronnie Bledsoe 2006 Dutchstar 43''s Avatar
 
Join Date: Oct 2006
Location: Manteca, Ca
Posts: 1,340
Tech suppoet is excellent. My fan would turn off, but it stayed at max speed when turned on to Auto or manual. Called tech support and they went thru some trouble shooting determined bad board, sent me a new board at my next destination at no charge.
__________________
"Piddln"
2008 Jeep Sahara '4Dr"
Ronnie Bledsoe
Ronnie Bledsoe 2006 Dutchstar 43' is offline   Reply With Quote
Old 06-01-2010, 08:03 PM   #7
Senior Member
 
Workhorse Chassis Owner
Join Date: Apr 2010
Location: Trenton NE
Posts: 244
Thanks for the feedback. I am going to call tomorrow.
__________________
Alleyman is offline   Reply With Quote
Old 06-01-2010, 08:05 PM   #8
Senior Member
 
Join Date: Mar 2007
Location: Southern California
Posts: 254
Quote:
Originally Posted by Alleyman View Post
The motor on "fantastic fan vent", keeps running even when switch is turned off. Only way I can stop it is take out the fuse. Is this a circuit biard problem or ??? Thanks for any help. Alleyman. 2004 Dolphin

I had that occur last year and the tech sent me a whole new assembly with detailed instructions for upgrading my model. When I explained what happened he knew immediately what to send.

Call them and parts will be in mail immediately.

Bob
__________________
99DutchStarDP

Southern California
BZam is offline   Reply With Quote
Old 06-01-2010, 09:48 PM   #9
Senior Member
 
Vegasdan's Avatar
 
National RV Owners Club
Freightliner Owners Club
Join Date: Oct 2009
Posts: 1,873
Quote:
Originally Posted by BZam View Post
I had that occur last year and the tech sent me a whole new assembly with detailed instructions for upgrading my model. When I explained what happened he knew immediately what to send.

Call them and parts will be in mail immediately.

Bob
I also had a problem with mine even turning on. I received a whloe new fan motor, blade, and lid raising motor assembly N/C. Fantastic is the best company out there.
__________________
2001 National Tradewinds 7370 300 Cat
2011 Jeep Wrangler Unlimited Sport
Officially fulltiming. The Journey Begins
Vegasdan is offline   Reply With Quote
Old 06-01-2010, 10:01 PM   #10
Senior Member
 
Join Date: Apr 2010
Posts: 689
Even tho Fantastic Fans are sold with a supposed warranty period they will keep on supplying replacement parts after the warranty is up by calling the factory techs. Even tho they produce a very good product from time to time some gremlin will pop up even years after installation and they have always stood behind their product. I personally wouldn't even consider another brand.
__________________
RVhauler is offline   Reply With Quote
Old 06-03-2010, 08:20 PM   #11
Senior Member
 
Workhorse Chassis Owner
Join Date: Apr 2010
Location: Trenton NE
Posts: 244
Follow up on my Fan-tastic vent fan problem. I called tech support at the factory and they were great. He diagnosed my problem as a bad motor and put un in the mail to at no charge. Also included a drive gear assembly. Unbelievable customer service. Thanks for the help. The folks at Fan-tastic Fan are "FANTASTIC"!!! Alleyman. 2004 Dolphin 5355
__________________

__________________
Alleyman is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hazard Flasher Problem Ms. Jean Thor Industries Owner's Forum 17 08-28-2014 05:54 PM
turn signal fuse blowing problem pschroede17 Winnebago Industries Owner's Forum 1 01-07-2010 10:44 PM
Workhorse vent system ??? stearn Workhorse and Chevrolet Chassis Motorhome Forum 13 12-13-2009 12:44 AM
Fantastic Vent Model 6600 Upgrade w/ Wireless Remote Control DriVer Gear and Product Discussions 32 05-01-2009 07:37 AM
xantrex auto gen start problem Techie RV Systems & Appliances 3 09-15-2008 07:54 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:17 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.