Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-18-2015, 08:21 PM   #1
Junior Member
 
Join Date: Feb 2011
Posts: 6
Question Atwood hot water heater

I have an Atwood 10 gal hot water heater. It works on Gas or Electric. My problem is that the water only gets warm, not hot. The temperature is the same on gas or electric. It has been working great but now that we are 2500 miles from home it decided to start this problem. Any help will be greatly appreciated. Thank you for looking.
Gene
__________________

__________________
skylark is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-18-2015, 08:31 PM   #2
Senior Member
 
jfran304's Avatar
 
Tiffin Owners Club
Workhorse Chassis Owner
Join Date: Oct 2009
Location: Warner Robins, GA
Posts: 2,486
Make sure the faucets on the outside shower are closed good.

Jon
__________________

__________________
Jon & Sue Francis (Retired U.S.A.F.)
Lil Girl-Rescued, Abby Rescued, Peaches Rescued
06 Allegro 35TSA Workhorse Chassis
2013 Chevy Spark Dinghy
jfran304 is offline   Reply With Quote
Old 10-18-2015, 08:48 PM   #3
Senior Member
 
Join Date: Sep 2012
Posts: 5,948
The common parts seem to be the thermostat and the control board. You need to know the model number to go deeper. This link will give you a parts clue:

http://www.atwoodmobile.com/manuals/...rPartsList.pdf

FWIW I would start by looking everything over and wiggling or unplugging and replugging all the connections with the power off. Also look for any adjustments some gremlin might have turned. If you are lucky it was a gremlin. If not parts are available.
__________________
nothermark is offline   Reply With Quote
Old 10-18-2015, 09:14 PM   #4
Senior Member
 
aschuh53's Avatar
 
Ford Super Duty Owner
Join Date: May 2013
Posts: 1,126
could be acouple of things May need to flushed also check by pass valve at tank could be themostat acting up but does not sound as if that is the cse also check for aslow leak
__________________
Allan&Mary with Daisy Dog&peanuts
1999 Newmar Mountian Aire 3758 37.5 ft V10
living life like there is know tomorrow
aschuh53 is offline   Reply With Quote
Old 10-19-2015, 05:18 PM   #5
Member
 
Join Date: Aug 2013
Posts: 45
Same problem came up last week for us.Water in past always hot now only warm either gas or electric mode or both.Ordered new thermostat and Eco should have by Friday,if this fixes I'll post later.
__________________
Kathy And John from SC
2004 revolution 40c
2000 Wrangler
Lkmurrytiger is offline   Reply With Quote
Old 10-19-2015, 05:47 PM   #6
Junior Member
 
Join Date: Feb 2011
Posts: 6
Thanks for all the inputs/ A new thermostat fixed my problem.
__________________

__________________
skylark is offline   Reply With Quote
Reply

Tags
atwood, heat, heater, water, water heater



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atwood Water Heater Issue. CaymanPilot Monaco Owner's Forum 6 08-21-2015 04:15 PM
On-Demand Hot Water Heater & LG Combo steamyb RV Systems & Appliances 2 08-16-2015 06:14 AM
Hot water heater plug busted janieD Excel Owner's Forum 23 04-30-2015 09:52 AM
Atwood hot water heater orrconst RV Systems & Appliances 9 02-09-2015 03:38 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.