RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-20-2018, 05:14 PM   #1
Junior Member
 
Join Date: May 2018
Posts: 1
Auxiliary switch issue?

I have a 2004 Tioga Fleetwood class C 29ft RV. If I push my auxiliary button on I just get a dim light and nothing happens. If I turn my engine on and then I press my auxiliary button on the switch turns on and I have full auxiliary's battery power. If I turn my generator on my auxiliary battery flickers and nothing happens. If I turn my engine on once again everything is fine and I can turn my generator on with my auxiliary battery then on. It seems like a battery switch issue??

When I am dry camping I will go to sleep at night with a full battery charge and wake up in the morning with my fridge off and the switch also off. Showing zero battery charge. If I turn my engine on once again the switch works and full battery charge shows this is very weird.
__________________

Kenney0918 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-20-2018, 06:36 PM   #2
Member
 
Tiffin Owners Club
Join Date: Nov 2016
Posts: 55
Everything seems to point to a house battery issue:
Low coach (aux) battery could make the aux button non-op if it is powered by the aux batt system. When the engine runs the chassis batt (engine) connect to the aux battery and everything works.
Two possibilities come to mind: bad aux battery(s) or bad cell in an aux batt.
2nd is a corroded cable connection on the aux batt system.
And one more bonus possibility - very low water in the aux batteries.
Time to get out the voltmeter along with some gloves and wrenches...
__________________

DFitz is offline   Reply With Quote
Old 05-21-2018, 02:54 AM   #3
Senior Member
 
ThePowells's Avatar


 
Join Date: Mar 2017
Location: Zebulon, NC
Posts: 2,629

Welcome to the forum. We're sorry that it took a problem to get you to join, but we hope that you will stay engaged after you have a resolution.
__________________
Kelly and Jerry Powell with Halo (Lethal White Aussie), Nash the Rat Terrorist, and now Reid, the "Brindle we have no idea puppy"
2017 Thor Quantum W31, Ford E-450, Onan QG4000, Demco Kar Kaddy, Toytoada Prius.
ThePowells is offline   Reply With Quote
Old 05-22-2018, 09:51 AM   #4
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 31,721
Hi ! Welcome to IRV2! We're sure glad you joined the gang!

Don't have an answer for that one!

Good luck, happy trails, and God bless!
__________________
Joe & Annette

2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Reply

Tags
switch



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Issue that is fixed pressing auxiliary start switch for 20 secs ssterbenz Class A Motorhome Discussions 7 11-10-2015 09:26 AM
Auxiliary battery switch on or off when ewaldo Winnebago Industries Owner's Forum 13 03-16-2013 11:26 AM
Auxiliary Battery Disconnect Switch ep120794 National RV Owner's Forum 5 02-24-2012 09:30 PM
Auxiliary blower switch? Wannabe Monaco Owner's Forum 6 10-06-2011 10:47 PM
03 Pace Arrow auxiliary boost switch---Help MrMudstud Fleetwood Products Owner's Forum 5 10-31-2009 09:46 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:36 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.