Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-13-2010, 03:06 PM   #1
Senior Member
 
Poltax's Avatar
 
Join Date: Jan 2003
Posts: 108
Battery Voltage Readout Gauge

I have a 2002 HR 40DST. My digital volt readout on my inside panel is acting up. All it reads is 1888 on both house and chassis settings. Never had a problem with this until about a month or so ago.

Batteries are hooked up properly. No changes to the electrical system that would have effected this.

Thank you
__________________

__________________
We dont race on Elvis's Birthday
Poltax is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-19-2010, 07:59 PM   #2
Senior Member
 
Shadowcatche's Avatar
 
iRV2 No Limits Club
Join Date: Nov 2010
Posts: 1,219
A VOM is your friend, check the reading at the meter, that will tell you if it is the meter or something in the circuit, then work your way forward.
__________________

__________________
Shadowcatche is offline   Reply With Quote
Old 11-21-2010, 04:04 PM   #3
Senior Member
 
hamguy's Avatar
 
Workhorse Chassis Owner
Join Date: Nov 2003
Location: Mesa, AZ USA
Posts: 1,806
Quote:
Originally Posted by Poltax View Post
I have a 2002 HR 40DST. My digital volt readout on my inside panel is acting up. All it reads is 1888 on both house and chassis settings. Never had a problem with this until about a month or so ago.

Batteries are hooked up properly. No changes to the electrical system that would have effected this.

Thank you
7-segment LED read an 8 when being tested. That shows all of the segments. A-2 segment (needed for the number 1 is the other device). I suspect you have a faulty readout!

__________________
Wretched excess is just barely enough.

2002 Itasca Suncruiser - WH Chassis - 35U - 2006 Jeep Liberty
hamguy is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery Voltage Orchardhill Fleetwood Products Owner's Forum 3 06-04-2010 09:35 AM
Need a battery guru deputydog RV Systems & Appliances 14 06-04-2010 09:22 AM
Chasis Battery codgerbill Winnebago Industries Owner's Forum 26 02-03-2009 06:27 AM
Battery not charging TallPaul Gulf Stream Owner's Forum 16 01-10-2008 04:00 PM
Solved my engine battery drain problem. Bo MH-General Discussions & Problems 6 09-27-2005 06:01 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:25 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.