Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Closed Thread
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-12-2008, 01:12 PM   #1
Senior Member
 
Appalachian Campers
Carolina Campers
Join Date: Apr 2008
Location: Wilmington, NC
Posts: 227
I posted this also in the Fleetwood forum, NEED HELP!

1996 Pace Arrow Vision; F 53 Ford; 460 carb.

The day I bought my MH, when headed home after 100 miles I lost almost all the brakes. I was in slow stop and go traffic and I figured they just got hot. Stopped for dinner and let them cool, no improved results. Went to the nearest Ford dealer, to have them checked, they said it was a bad Master cylinder. Not in stock, has to be ordered. I still had some brakes so being only 125 miles from home and it was evening, I took a chance and came home.

Ordered the Master cylinder and had it replaced. I think they also replaced all the old brake fluid. Everything works fine. Since then we have made a couple of trips without any brake problems.

Having not used the MH for several months, I made a short run about 30 miles each way to fix a work problem. Everything OK. On the return trip I went about 1 mile to a stop sign and NO BRAKES! Pedal almost to the floor, but I still had the little brakes that I had on my very first trip. I had to get home so I took it very easy. Ten miles later, the stop light changed and I coasted before hitting the brakes. NOW I ONCE AGAIN HAVE FULL BRAKES. Tried it several more times and everything is OK.

Get almost home, again lost brakes.

What would be causing them to come and go?
__________________

__________________
Poppy & Grammy
Drake the rescue Yellow Lab
2005 Providence 39L - 2009 Buick Enclave
Just Because is offline  
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-12-2008, 01:12 PM   #2
Senior Member
 
Appalachian Campers
Carolina Campers
Join Date: Apr 2008
Location: Wilmington, NC
Posts: 227
I posted this also in the Fleetwood forum, NEED HELP!

1996 Pace Arrow Vision; F 53 Ford; 460 carb.

The day I bought my MH, when headed home after 100 miles I lost almost all the brakes. I was in slow stop and go traffic and I figured they just got hot. Stopped for dinner and let them cool, no improved results. Went to the nearest Ford dealer, to have them checked, they said it was a bad Master cylinder. Not in stock, has to be ordered. I still had some brakes so being only 125 miles from home and it was evening, I took a chance and came home.

Ordered the Master cylinder and had it replaced. I think they also replaced all the old brake fluid. Everything works fine. Since then we have made a couple of trips without any brake problems.

Having not used the MH for several months, I made a short run about 30 miles each way to fix a work problem. Everything OK. On the return trip I went about 1 mile to a stop sign and NO BRAKES! Pedal almost to the floor, but I still had the little brakes that I had on my very first trip. I had to get home so I took it very easy. Ten miles later, the stop light changed and I coasted before hitting the brakes. NOW I ONCE AGAIN HAVE FULL BRAKES. Tried it several more times and everything is OK.

Get almost home, again lost brakes.

What would be causing them to come and go?
__________________

__________________
Poppy & Grammy
Drake the rescue Yellow Lab
2005 Providence 39L - 2009 Buick Enclave
Just Because is offline  
Old 10-12-2008, 02:22 PM   #3
Registered User
 
SacsTC's Avatar
 
Monaco Owners Club
Join Date: Nov 2006
Location: Sacramento, CA.
Posts: 846
Going from what you say, I would think it is the Vacuum cylinder.
__________________
SacsTC is offline  
Old 10-12-2008, 02:36 PM   #4
Community Administrator
 
Route 66's Avatar


 
Newmar Owners Club
Retired Fire Service RVer's
Spartan Chassis
Join Date: May 2000
Location: Newark, DE
Posts: 25,606
Duplicate post.

Other post HERE.
__________________
Adios, Dirk - '84 Real Lite Truck Camper, '86 Wilderness Cimarron TT, previously 4 years as a fulltimer in a '07 DSDP

Route 66 is offline  
Closed Thread



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Air Brakes or Hydraulic Brakes? Stretch Alpine Coach Owner's Forum 35 03-28-2017 03:09 PM
brakes melvin 410 Toads and Motorhome Related Towing 13 11-05-2008 02:37 PM
Anyone know where I can get new brakes American Eagle MH-General Discussions & Problems 4 05-01-2008 05:50 AM
brakes annabelle MH-General Discussions & Problems 4 02-25-2007 02:38 AM
Brakes Freightliner Motorhome Chassis Forum 6 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:29 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.