Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 08-26-2014, 09:42 AM   #1
Junior Member
Join Date: Aug 2014
Posts: 1
coach batteries

I am having a problem whenever I am plugged into shore power. My batteries are getting drained. They charge back up again when I have the engine or generator running, but shore power of any amperage is sucking the life out of them. Could this be a faulty power converter? Or does anyone have any other ideas?

RayV is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-26-2014, 09:49 AM   #2
Senior Member
Skip426's Avatar

Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 11,954

Faulty convertor is a possibility.
My coach has a dedicated 110v circuit breaker for the convertor / charger, and that would be the first thing to check, also breakers on the C/C it's self; it may have some.
If you can find and post info on the C/C that's in you coach , maybe we can track down a manual and testing info , if you don't have it already.

99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 08-26-2014, 09:49 AM   #3
Senior Member
Cypressloser's Avatar
Join Date: Sep 2013
Location: East of the Rockies and West of the Rest
Posts: 413

It could be a problem with your converter/charger but a lot more info is needed about your RV.
2013 RAM 3500 Longhorn Dually, Andersen Ultimate 5th Wheel Hitch,2014 Trilogy 3650 RL, 8000# axles, disk brakes, I.S., 960 Watt Solar
Cypressloser is offline   Reply With Quote
Old 08-26-2014, 11:46 AM   #4
Moderator Emeritus
Gary RVRoamer's Avatar

Fleetwood Owners Club
Freightliner Owners Club
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 16,436
Since your batteries charge ok on generator, it seems your converter must be working OK. All the generator does is provide an alternate source of shore power - it does not charge batteries on its own.

Please provide more details, starting with year/make/model of coach and brand/model of the charging system (converter/charger).
Gary Brinck
2004 American Tradition; 2014 Buick LaCRosse
Homebase in the Ocala Nat'l Forest near Ocala, FL
Gary RVRoamer is online now   Reply With Quote
Old 08-27-2014, 01:46 PM   #5
jetdoc's Avatar
Join Date: Jan 2014
Posts: 35
My 1st rv was a 2002 georgie boy v-10. The batteries would never charge off of the converter. Found Under the hood in the electrical panel the reset button was out on either a 30 or 50 amp reset. The converter would provide full power to the rig just wouldn't power the batteries
jetdoc is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Inteli Power 9100 not charging batteries... -LB- National RV Owner's Forum 18 11-18-2014 04:29 AM
How do I run the coach on the house batteries? Goofaroo RV Systems & Appliances 26 05-04-2014 12:10 PM
Batteries not charging while coach running LMM Winnebago Industries Owner's Forum 1 04-23-2014 02:33 PM
Can I run the Genny without coach batteries connected? Kliwks Class A Motorhome Discussions 21 03-19-2014 08:46 AM
Coach batteries rivrduk National RV Owner's Forum 5 12-21-2013 08:59 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:00 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.