Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 12-09-2010, 12:12 AM   #1
Junior Member
Join Date: Nov 2009
Posts: 16
Cruise Control Problems, 1996 Dodge B3500, 5.2L

Our cruise control just started acting up. It worked perfectly in the past. The green light comes on when we turn the cruise control on. But nothing happens when we press the "set" button. When pressing the "set" button, the van does not accelerate so we can designate a constant speed. Sometimes, if we fiddle with the "resume" button and the accelerator pedal, the cruise control kicks in. (possibly at a previously set speed?) But, even after doing the "resume" button/accelerator pedal fiddling, the speed doesn't remain constant; sometimes the van keeps accelerating without pressing the accelerator. The cruise always turns off, as it should, when the brake pedal is depressed.

Where do I start checking? Is the switch on the steering wheel bad? The cruise servo module? The cruise vacuum canister? The Dodge Service Manual says the cruise servo module and vacuum canister are located behind the passenger-side front fender extension, but I wanted to get some opinions before I started digging into anything.

Thanks, Tom

1996 Fleetwood Bounder 38Z, Ford F53 chassis, 460 motor
1996 Pleasure-Way STW, Dodge B3500 chassis, 318 motor
tomnorman457 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-09-2010, 04:11 AM   #2
Community Moderator
"007"'s Avatar

Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 24,471
The set switch maybe bad plus there maybe a switch on brake pedal that if possible can be adjusted when brake is fully in rest position.
For example the switch on the Workhorse chassis can be adjusted by turning the brake released plunger in or out. You may have same if its that type switch if not need new one.

98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
"007" is offline   Reply With Quote
Old 12-17-2010, 10:42 PM   #3
Junior Member
Join Date: Nov 2009
Posts: 16
UPDATE: It's Fixed

I removed the small section of fender trim to access the cruise control components. And I found out why the cruise control wasn't working. The vacuum lines and fittings were all OK. But a support "leg" for the black plastic cruise control vacuum reservoir had snapped off, making a large hole, meaning no vacuum was going to the cruise control servo. I used a liberal application of plumber's "Goop" to repair the vacuum reservoir, and let it cure overnight. The cruise control worked flawlessly today when I road-tested it. Tom
1996 Fleetwood Bounder 38Z, Ford F53 chassis, 460 motor
1996 Pleasure-Way STW, Dodge B3500 chassis, 318 motor
tomnorman457 is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
cruise control not working 1990 Fleetwood P30 chevy 454 chassi tspivey0534 MH-General Discussions & Problems 3 05-09-2010 03:09 PM
Headlight adjustment and cruise control tatcha n reddog National RV Owner's Forum 4 01-04-2010 04:15 PM
2004 Allegro 32BA Cruise Control quit working? k1hog Workhorse and Chevrolet Chassis Motorhome Forum 7 07-31-2009 11:03 AM
Cruise Control Vibration Rick Coleman Alpine Coach Owner's Forum 19 06-10-2008 07:31 PM
Jake Brake in Cruise Control? OldForester Alpine Coach Owner's Forum 20 07-19-2007 06:05 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:14 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.