Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-21-2008, 06:11 PM   #1
Junior Member
 
Join Date: Mar 2007
Posts: 9
We have a 2005 Thor Infinity Class A motorhome with a Chevy workhorse chassis. While traveling from Minnesota to Alabama, all of the dashboard indicator lights and alarm came on for about 20 seconds and then went back off three times during the trip. No problem with the engine, just a scare as we were driving. Have heard there have been a recall on this. Would like to find out before we make the return trip in 2 weeks.

mlkramer@mchsi.com
__________________

__________________
Kramer-MN is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-21-2008, 06:11 PM   #2
Junior Member
 
Join Date: Mar 2007
Posts: 9
We have a 2005 Thor Infinity Class A motorhome with a Chevy workhorse chassis. While traveling from Minnesota to Alabama, all of the dashboard indicator lights and alarm came on for about 20 seconds and then went back off three times during the trip. No problem with the engine, just a scare as we were driving. Have heard there have been a recall on this. Would like to find out before we make the return trip in 2 weeks.

mlkramer@mchsi.com
__________________

__________________
Kramer-MN is offline   Reply With Quote
Old 03-21-2008, 06:55 PM   #3
Senior Member
 
al koffman's Avatar
 
Workhorse Chassis Owner
Join Date: Feb 2000
Location: Kingman Az usa
Posts: 226
What you have experianced has happened to many of us, fortunately, not very often. There is no recall for this, and hopefully it won't happen again.
__________________
Al

2004 Allegro 32BA W20
al koffman is offline   Reply With Quote
Old 03-22-2008, 05:09 AM   #4
Senior Member
 
Workhorse Chassis Owner
Join Date: Sep 2007
Location: st.charles mo.
Posts: 1,194
I would check the conector on the back of the dash. I unpluged mine and reconnected them and have not had a problem.
__________________
speed racer is offline   Reply With Quote
Old 03-22-2008, 05:49 AM   #5
Senior Member
 
Ding-a-ling's Avatar
 
Winnebago Owners Club
Join Date: Aug 2004
Location: Zephyrhills, FL
Posts: 935
Kramer,
Welcome to iRV2.com.

What occurs is really nothing to worry about. Workhorse Chassis uses a computerized instrument panel made by a company called Actia. What happens is that false signals are induced upon the data bus over which many sensors report to the IP. This causes the computer chip to do a reset and then things go back to normal. Happens to most of us Workhorse owners at one time or another. It was really startling the first time it happened to me.

Here is a link to a previous discussion on this.
__________________
'14 Winnebago Vista 35F, '14 GMC Terrain
BlueOx Towing Pkg, SMI Stay-n-Play
49 States & 7 Provinces visited in MH | WIT W112365
Ding-a-ling is offline   Reply With Quote
Old 03-23-2008, 12:48 PM   #6
Senior Member
 
Duner's Avatar
 
Winnebago Owners Club
Workhorse Chassis Owner
Join Date: Jul 2002
Location: Fulltiming now in- Menifee, CA
Posts: 1,225
Kramer, welcome aboard!!! IRV2 is the greatest source of RV info you'll find on the web.

There was a recall on the Actia IP regarding brake ABS warning light, but I don't know if it affects your model year.

I suggest that you get your VIN # and go to the Workhorse Website Link. Click on "My Workhorse" and create your account. Once they have your VIN, you can see all the open & closed recall campaigns for your chassis. You can also read the details of the recalls.

In 4 years I've had my IP burp many times (6-10) and it always seems to recover ok. I've checked the connectors in the back of the IP and the ground wires to the frame, but never discovered anything.

Good luck and many happy miles,
__________________
Bill (Dune'r) & Helen
Last of the Chieftains, 2004 39T, W22, Banks Headers, Koni's, Safe-T-Plus, SMI brake
2017 Lincoln MKZ Hybrid towed 4-down
https://www.irv2.com/attachments/signaturepics/sigpic23522_1.gif]
Duner is offline   Reply With Quote
Old 03-24-2008, 05:12 PM   #7
Senior Member
 
stubeje's Avatar
 
Workhorse Chassis Owner
Join Date: Oct 2007
Posts: 152
Kramer...my 2005 Newmar did the same thing and I was told by Workhorse that it is a software problem that they have been working on since 2003 model and still don't have it fixed but that it wouldn't hurt anything...also if your cluster does fail or start to fade that they will replace it after warranty for just the labor which is .6 hrs. labor.
__________________

__________________
Newmar Kountry Star 2005 37'

8.1 Workhorse w/UltraPower,Taylor 409 plug wires,AC Delco 41-993 Plugs and OEM Engineering Fuel Filter Adaper
stubeje is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Holding Tank Indicator Lights the basher Fleetwood Products Owner's Forum 4 09-12-2008 08:12 AM
black water tank indicator lights richierich Winnebago Industries Owner's Forum 20 09-21-2007 07:09 AM
Holding Tank Indicator Lights alanz New Member Check-In 12 01-27-2007 12:36 AM
New Dash Indicator Lights shelland Alpine Coach Owner's Forum 1 02-05-2005 01:36 PM
Holding Tank Indicator Lights Newmar Owner's Forum 14 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:28 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.