Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-15-2006, 11:31 AM   #1
Junior Member
 
Join Date: Aug 2006
Location: Washington DC Metro Area
Posts: 3
have a 2005 Beaver Monterey. My chassis batteries will discharge on occasion. I have isolated the problem to either the "BIRD" Module or the Big Boy Solenoid. Maybe it is both. Since this is an intermittent problem, can someone help me further diagnose the problem

Thanks
__________________

__________________
Dennis & Susan

2005 Beaver Monterey 38 Foot
MD_FL_Boy is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-15-2006, 11:31 AM   #2
Junior Member
 
Join Date: Aug 2006
Location: Washington DC Metro Area
Posts: 3
have a 2005 Beaver Monterey. My chassis batteries will discharge on occasion. I have isolated the problem to either the "BIRD" Module or the Big Boy Solenoid. Maybe it is both. Since this is an intermittent problem, can someone help me further diagnose the problem

Thanks
__________________

__________________
Dennis & Susan

2005 Beaver Monterey 38 Foot
MD_FL_Boy is offline   Reply With Quote
Old 08-15-2006, 11:56 AM   #3
Moderator Emeritus
 
Joe-K's Avatar


 
Tiffin Owners Club
Pond Piggies Club
Join Date: Mar 2000
Location: Butler, PA
Posts: 1,828
Hi MD_FL_Boy,

First off, welcome to iRV2. Glad you registered and posted your question.

My previous rig had a BIRD module, which as I'm sure you know is designed to permit charging of a dual battery system where both batteries have separate charging sources. When either of the charging sources is providing sufficient charging voltage, the battery banks are connected and charge, however when the charging voltage is reduced or eliminated, the batterys isolate to prevent discharging of the chassis batteries.

Several years ago, I had some questions regarding the operation of my unit on a previous rig and spoke with the folks at Intellitec. I can tell you, their technical service department was sharp and answered all my questions and walked me through some troubleshooting steps. I'd suggest calling them at 1-800-251-2408 and explaining your problem.

As other helpful information, check out the Technical Service Manuals for all their products including the BIRD modual.

Here also is the direct link for the BIRD Modual service manual The service manual identifies the defect symptom of chassis battery discharging into coach. Again though, if the manual doesn't give a good enough diagnostic method, give em a call.

Good luck with the troubleshooting.
__________________
Joe & Shelly, Justin, Tyler, Alyssa | Butler PA
2008 Tiffin Allegro Bus 43QRP|Cummins 425|Honda CRV
Joe-K is offline   Reply With Quote
Old 08-16-2006, 01:12 AM   #4
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
MD_FL_BOY, Welcome to iRV2.com. We are glad to have you join us here and look forward to reading of your adventures and experiences. I am sure you will enjoy the forum and hope you will be an active participant on it. Good luck in the troubleshooting of the battery issues. You have some great info given to you to help.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 08-16-2006, 03:40 AM   #5
Junior Member
 
Join Date: Aug 2006
Location: Washington DC Metro Area
Posts: 3
Joe-K,

Thanks. I really think it is the Big Boy solenoid. My guess is that is engages and all is fine for a low level charge, but if something comes on (like the electiric air pump) and puts a load on the Chassis batteries, it can't take it. Hopefully, I will get the new parts soon.
__________________
Dennis & Susan

2005 Beaver Monterey 38 Foot
MD_FL_Boy is offline   Reply With Quote
Old 08-17-2006, 08:05 PM   #6
Bo
Member
 
Join Date: Feb 2000
Location: Loveland, CO, USA
Posts: 58
You might have the problem I posted on quite some time ago. You can find it here: Phantom battery leakage or do a search on my name in this forum. My neighbor has a 2005 Winnebago A diesel pusher that had the same problem. I have perfected the diode fix and have had no problem since installing it.
__________________

__________________
Larry (If you don't care where you are you ain't lost) 2010 Ram 3500 Cummins CC LB 4x4, 24 ft. Nomad fifth with slide, 9 ft. Elkhorn slide in, 2001 Starflyte by DynaMax 21 ft., V10.
Bo is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Chassis Batteries ronharp Newmar Owner's Forum 2 03-31-2008 09:45 AM
Chassis Batteries saydiver Newmar Owner's Forum 6 02-08-2008 08:34 PM
Chassis Batteries Go Down Mikeso Winnebago Industries Owner's Forum 11 01-07-2008 07:54 AM
Chasis Battery Discharging Matt-n-Dede Freightliner Motorhome Chassis Forum 6 09-16-2007 01:12 PM
Chassis batteries nutensteve Monaco Owner's Forum 3 03-02-2007 03:38 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:53 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.