Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-24-2012, 05:28 PM   #1
Junior Member
 
Join Date: Feb 2012
Posts: 5
EMS 900 Problem

Hello , I am new here and i hope someone can help me . I have an Intellitec EMS 900 and the display panel is all lite up when i am on battery power only . I called Intellitec and the tech said no one has ever asked him about this before and he was no help . Does anyone have any idea what i should look for ?
__________________

__________________
Papajohn7 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-25-2012, 02:31 PM   #2
Senior Member
 
Jim_HiTek's Avatar
 
Join Date: Nov 2011
Location: Full time RV'er
Posts: 1,659
Yikes. Doesn't sound good but I know what I'd try. Remove all power sources and let it sit for awhile. Check any circuit breakers to be sure none of them are 'partially opened'. Disconnect the ground leads at the batteries...and check the battery voltages while in there to make sure a shorted battery cell isn't causing problems. Good luck, hope it works out to be something simple.

Call Intellitec back and try to get a different tech.
__________________

__________________
'02 Winnebago Journey DL, DSDP, 36' of fun.

Visit my RV Travel & Repair Blog at : http://chaos.goblinbox.com
Jim_HiTek is offline   Reply With Quote
Old 02-25-2012, 02:43 PM   #3
Community Administrator
 
Clifftall's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Aug 2009
Posts: 29,136
Quote:

Call Intellitec back and try to get a different tech.
Good advice right there
__________________


Cliff,Tallulah and Buddy ( 1999-2012 )
Clifftall is offline   Reply With Quote
Old 02-26-2012, 06:10 AM   #4
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
Hello papajohn7 and . We are glad to have you join us here and we look forward to reading of your adventures and experiences. I am sure you will enjoy the website and forums. Good luck, stay safe and keep us posted.
Go here iRV2 Forums - Files - Smart EMS model 900 for an installation and service manual if you do not have one. A better description or photo of "all lit up" would be helpful.
Good luck and let us know what you find or have more questions.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New problem on my 91 oshkosh ford 460 chassis Bilito Vintage RV's 29 04-24-2012 10:35 PM
RV Water Heater Problem sooner RV Systems & Appliances 5 02-26-2012 08:14 PM
Hwh air leveling problem BBSON Country Coach Owners Forum 7 02-23-2012 06:01 PM
EMS jlyon69 National RV Owner's Forum 0 02-23-2012 08:10 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:11 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.