Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-28-2006, 08:39 AM   #1
Junior Member
 
Rosewood Works's Avatar
 
Join Date: Jun 2006
Location: La Mesa, CA
Posts: 4
Help!!!! 34H Meridian Freightlier Chassis, Cat C7 350 Less then 2500 miles. While driving home after Del. at 65MPH on flat freeway it just quit, like someone turned the key off. Everthing was dead, no dash lights nothing. After waiting 40 to 45 minutes it would restart.

Two days later (about 600 miles) the same thing. Shut down at 65mph, everthing dead, Restart after about 45 minutes.
__________________

__________________
Rosewood Works is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-28-2006, 08:39 AM   #2
Junior Member
 
Rosewood Works's Avatar
 
Join Date: Jun 2006
Location: La Mesa, CA
Posts: 4
Help!!!! 34H Meridian Freightlier Chassis, Cat C7 350 Less then 2500 miles. While driving home after Del. at 65MPH on flat freeway it just quit, like someone turned the key off. Everthing was dead, no dash lights nothing. After waiting 40 to 45 minutes it would restart.

Two days later (about 600 miles) the same thing. Shut down at 65mph, everthing dead, Restart after about 45 minutes.
__________________

__________________
Rosewood Works is offline   Reply With Quote
Old 06-28-2006, 03:52 PM   #3
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 18,073
Strange indeed! Call Freightliner and ask?
__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Old 06-28-2006, 05:15 PM   #4
Senior Member
 
Join Date: Oct 2003
Posts: 349
Had similar problem...finally found a bad relay that supplies 125 amps to the entire chassis...When it finally went totally dead and was easier to find the problem...On your chassis it is located on the passenger side frame rail just opposite the transmission...There is a metal plate with 3 relays attached...the one furthest to the rear is the one that shuts everything down and is probably the problem, the 2nd one is for the heater coil in the inlet of the air scoop and the 3rd one is for the starter relay and soloniod.
If you experiece a total shut down again, find the relay (can easily be done from underneath)and remove the cable that comes from the engine battery and attach it directly to the other terminal on the relay...there are 2 terminals, an in and an out...Better yet buy a 8 guage battery cable with terminal loops at each end and jump the connections.
The relay is available from Freightliner or Napa....good luck and carry a spare...they are made in Mexico and have a history of failing....RKL
__________________
RKL2 is offline   Reply With Quote
Old 06-28-2006, 07:05 PM   #5
Junior Member
 
Rosewood Works's Avatar
 
Join Date: Jun 2006
Location: La Mesa, CA
Posts: 4
Thanks for the info, Freightliner said it should be a breaker just like you said, but gave me no info as to were it is located. They are replacing it today. Rosewood works
__________________
Rosewood Works is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel Gauge Dies shelland Alpine Coach Owner's Forum 9 03-05-2009 03:02 PM
starter battery dies..and dies artro Newmar Owner's Forum 4 08-10-2007 11:37 AM
Bill France Jr. Dies at 74 DriVer RV Events & Gatherings 1 06-04-2007 11:51 AM
CAt 330 engine dies-lack of fuel in filter Motorhome05 Freightliner Motorhome Chassis Forum 8 02-11-2006 09:03 PM
CAt 330 engine dies-lack of fuel in filter Winnebago Industries Owner's Forum 8 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.