Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 03-12-2013, 05:03 PM   #15
Community Administrator
Clifftall's Avatar

Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Aug 2009
Posts: 24,520
Thanks for the update. Since you posted that the battery was charged , could you explain further ?


Cliff,Tallulah and Buddy ( 1999-2012 )
Clifftall is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-14-2013, 05:59 PM   #16
Junior Member
PeggyAnn's Avatar
Join Date: Dec 2012
Posts: 10
Originally Posted by Clifftall View Post
Thanks for the update. Since you posted that the battery was charged , could you explain further ?
The indicator light were showing 'charged' so that is what we were going by. I guess we have a lot to learn about our 2001 diesel RV.
Thanks for all your help.

PeggyAnn is offline   Reply With Quote
Old 03-14-2013, 06:10 PM   #17
Senior Member
Join Date: Apr 2012
Posts: 1,493
So I if I understand correctly, the house batteries indicated they were charged but the chassis battery (s) was not charged - is this correct?

Did you select the emergency start button and the engine started or what did you do to start the engine?

Good feedback always helps others.


Libero is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hazard Flasher Problem Ms. Jean Thor Industries Owner's Forum 17 08-28-2014 04:54 PM
Looking at 2011 Fleetwood Expedition 36M eav1952 Fleetwood Products Owner's Forum 1 04-03-2011 04:54 PM
2008 Fleetwood Expedition Slideout dberthelot Fleetwood Products Owner's Forum 6 07-08-2010 08:22 AM
Fleetwood To Break New Ground With Launch Of Fleetwood Vacation Club In Spring 2005 DriVer RV Industry Press 2 01-21-2005 12:34 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:03 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.