Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-01-2007, 11:07 AM   #1
Junior Member
 
Join Date: Mar 2007
Posts: 8
My old Dometic fridge lights up fine, but after maybe 10 minutes, sometimes an hour or whatever, it goes out.It works fine while lit, and also on 110 volts.I have a nice blue flame, no yellow,with a slight roar. Gas pressure is showing 11 inches on the gauge.Gas orifice and burner tube are very clean.I can't think of anything else to check.This has serious implications on my beer supply, so any ideas, guys? Thanks.
__________________

__________________
Brockhole is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-01-2007, 11:07 AM   #2
Junior Member
 
Join Date: Mar 2007
Posts: 8
My old Dometic fridge lights up fine, but after maybe 10 minutes, sometimes an hour or whatever, it goes out.It works fine while lit, and also on 110 volts.I have a nice blue flame, no yellow,with a slight roar. Gas pressure is showing 11 inches on the gauge.Gas orifice and burner tube are very clean.I can't think of anything else to check.This has serious implications on my beer supply, so any ideas, guys? Thanks.
__________________

__________________
Brockhole is offline   Reply With Quote
Old 05-01-2007, 12:12 PM   #3
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 26,781
Maybe this will be of help.

Tech libary
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 05-01-2007, 04:24 PM   #4
Senior Member
 
GaryKD's Avatar
 
Newmar Owners Club
Join Date: Jul 2006
Location: Wellington, Florida
Posts: 12,323
Could it be the thermocouple (the thing that needs to stay hot to keep the gas flowing) is bad or out of adjustment?
__________________
Gary
2005 Newmar KSDP 3910 + GMC ENVOY XUV 37K lbs Moving Down The Road
The Avatar Is Many Times Around The USA
Nobody Knows Your Coach Like Somebody Who Owns One Just Like Yours
GaryKD is offline   Reply With Quote
Old 05-01-2007, 05:24 PM   #5
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 26,781
Bet you hit the nail on the head Gary.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 05-01-2007, 05:29 PM   #6
Moderator Emeritus
 
TXiceman's Avatar


 
Vintage RV Owners Club
Texas Boomers Club
Oklahoma Boomers Club
Ford Super Duty Owner
Join Date: Aug 2000
Location: Full Time, TX Home Base
Posts: 17,150
Blog Entries: 21
First make sure the thermocouple is firmly tightened where it connects to the gas valve. Make sure the C is located in the flame. Next thing to do is to replace the TC.

Ken
__________________
Amateur Radio Operator (KE5DFR)|Full-Time! - 2012 6.7L Ford Crew Cab Dually -2013 HitchHiker Champagne 38RLRSB - Travel with one Standard Schnauzer and one small Timneh African Gray Parrot
TXiceman is offline   Reply With Quote
Old 05-02-2007, 03:07 AM   #7
Member
 
Join Date: Feb 2005
Location: Georgia
Posts: 81
My fridge did the same thing. It worked fine on 110 but on gas it would be working fine and then go off and switch to "auto" and would not relight. Turned out to be the control board. I put a new one in and no problems since.
__________________
The Beaver is offline   Reply With Quote
Old 05-02-2007, 04:14 AM   #8
Administrator in Memoriam
 
Hitchhiker's Avatar


 
Appalachian Campers
Join Date: Jan 2000
Location: Buladean, NC
Posts: 8,127
Mine would go out or not light, turned out to be a pinched rubber gas line underneath the slide containing the fridge.
__________________
'11 GMC Acadia SLT AWD
'11 GMC Sierra 1500 4x4 Extended Cab
Hitchhiker is offline   Reply With Quote
Old 05-02-2007, 08:59 AM   #9
Moderator Emeritus
 
smlranger's Avatar


 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,269
Blog Entries: 1
Before you go replacing gizmos, check for rust scale in the flue and burner area. Mine did similar thing and once I blew the rust and rust scale out, it works fine. I now do it annually.
__________________

__________________
'07 Country Coach Allure 470 Siskiyou Summit #31578, Cummins ISL 425; 2014 Ford F150 toad; Air Force One Toad Brake.
Glen Allen, VA; Smith Mountain Lake, VA.
smlranger is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Norcold fridge won't stay lit RobCN RV Systems & Appliances 5 09-21-2008 10:53 AM
Water Heater fails to keep lit Jackmann47 Vintage RV's 6 09-02-2008 08:55 AM
Dometic fridge won't stay lit Riverdog RV Systems & Appliances 10 07-26-2006 08:53 AM
w-22 dash lit up??? joelyn Workhorse and Chevrolet Chassis Motorhome Forum 7 08-22-2005 07:32 PM
Water Heater fails to keep lit RV Systems & Appliances 6 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:44 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.