Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-03-2014, 11:08 AM   #1
Junior Member
 
Join Date: Jan 2014
Posts: 5
Gen problem solved

A while back I posted my woes re a no-output generator problem with my Generac NP66G. (this in a '92 Safari)
To complicate things, the starter drive gave up the ghost during my trouble shooting.
Anyway, pulled the gen unit and replaced the starter drive, regulator and brush set. Reinstalled the gen and adjusted the new regulator to 121V. Done deal.
Total cost about $400 Dang, them Generac parts are not cheap!
__________________

__________________
Shacker is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-03-2014, 11:15 AM   #2
Senior Member
 
homeless's Avatar
 
Join Date: Mar 2012
Location: http://binged.it/1KdDqKO
Posts: 2,316
Blog Entries: 1
Thanks for the update!
__________________

__________________
homeless is offline   Reply With Quote
Old 04-04-2014, 08:25 AM   #3
Senior Member
 
Gormleys's Avatar
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Sep 2012
Location: CO
Posts: 674
Appreciate your update (just imagine what it would have cost had you taken it into a shop!)
__________________
Colorado '15 Winnebago Forza 34T w/MKZ hybrid toad
Gormleys is offline   Reply With Quote
Old 04-05-2014, 05:40 PM   #4
Moderator Emeritus
 
SarahW's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Oct 2011
Location: In a lawnchair
Posts: 11,204
Thanks for the update; glad you got it fixed!
__________________
.2012 Fleetwood Bounder 33C | 2012 Jeep Wrangler

SarahW is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1982 Onan 4K Genset won't start randini RV Systems & Appliances 32 03-24-2014 11:29 AM
Norcold frosting problem Navy Flier RV Systems & Appliances 3 02-22-2014 09:10 AM
Unusual Hydro Hot problem, and the fix Medico RV Systems & Appliances 0 02-14-2014 07:18 AM
Redneck 1993 Allegro Bay Diesel Pusher with electrical problem jcruce13 Class A Motorhome Discussions 7 10-09-2013 12:27 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:20 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.