RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-18-2019, 01:27 AM   #1
Member
 
MDBalin's Avatar
 
Join Date: Mar 2018
Location: Highland, Ca
Posts: 33
Generac 66G

Hello everyone Iím hoping I might get my Generac 66G issues straightened out.

Ok I have a 2001 Generac 66G on a Rexhall 3550BSL.
Is starts and runs without a load. Once I start one or both of the AC Units, it will run just for a short while and when the compressorís start up the genenset ideals down and the ACís seem to not like that one bit....and I shut the Genset off.

Iím not sure where to check or what I should start with on my diagnosis of this or these problems. I hope for a nice outcome so our trip that we are taking in 10days is a comfy one.

Thanks to all for input and your ideas.

Mike
__________________

MDBalin is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-18-2019, 02:05 AM   #2
Member
 
Join Date: Jul 2018
Posts: 37
First thing that comes to mind is the governor not working. There should be visible movement of the linkage going to the carburetor when load is applied.
__________________

csuder99 is offline   Reply With Quote
Old 08-21-2019, 08:00 PM   #3
Member
 
MDBalin's Avatar
 
Join Date: Mar 2018
Location: Highland, Ca
Posts: 33
The issue has been resolved....ended up being a starving issue.

The choke Solenoid was very gummed up...and stuck.

Took the choke all apart and cleaned. De gummed and also cleaned the heating element of the choke system.

All works well and “wee” I have A/C again...

Thanks to all of you that inputed info regarding generators. I will update if I have been stymied again.
__________________
2001 Rexhalle XL 3550 BSL
Demco Kar Kaddy SS
2015 Chevy Spark
MDBalin is offline   Reply With Quote
Reply

Tags
66g, generac, generator, rexhall



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Generac NP-66G JRMEDPHYS RV Systems & Appliances 11 05-20-2018 03:43 PM
Generac 66g does not start when damp outside. mdslight RV Systems & Appliances 2 01-19-2016 07:54 AM
Generac NP-66G A/C stalling eabale MH-General Discussions & Problems 6 03-18-2013 01:28 PM
1991 generac NP-66G genset Bilito Vintage RV's 17 04-11-2012 03:13 PM
Generac NP-66G Problem? John&Stacy RV Systems & Appliances 1 10-05-2010 10:23 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.