Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-21-2006, 04:07 PM   #1
Member
 
MONTANA RED's Avatar
 
Join Date: Jun 2005
Location: Kalispell mt.
Posts: 72
generator and electric outlet not charging coach batteries....The chassis engine does charge the batteries....has anybody had this problem?
__________________

__________________
MONTANA RED is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-21-2006, 04:07 PM   #2
Member
 
MONTANA RED's Avatar
 
Join Date: Jun 2005
Location: Kalispell mt.
Posts: 72
generator and electric outlet not charging coach batteries....The chassis engine does charge the batteries....has anybody had this problem?
__________________

__________________
MONTANA RED is offline   Reply With Quote
Old 10-21-2006, 04:12 PM   #3
Senior Member
 
Paulin's Avatar
 
Join Date: Sep 2003
Location: No. CA
Posts: 405
You might want to have the converter checked.
__________________
Paulin
Paulin is offline   Reply With Quote
Old 10-21-2006, 05:48 PM   #4
Senior Member
 
GStream40's Avatar
 
Join Date: Feb 2000
Location: Navarre, Ohio
Posts: 262
Do you have an Xantrex Inverter/Charger?

If you do the coach batteries are charged by the Xantrex. There is a switch/breaker on the front of the inverter, see if it is turned off or breaker is tripped.

Ron
__________________
Gulf Stream RV Owners Forum www.gsowners.com

GStream40 is offline   Reply With Quote
Old 10-22-2006, 07:34 AM   #5
Member
 
MONTANA RED's Avatar
 
Join Date: Jun 2005
Location: Kalispell mt.
Posts: 72
I have a inverter that is used just for the entertainment system ....does not have a charger.
__________________
MONTANA RED is offline   Reply With Quote
Old 10-22-2006, 08:54 AM   #6
Senior Member
 
Winnebago Owners Club
Join Date: Dec 2003
Location: MN,USA
Posts: 651
Check to see if you have a switch that disconnects your coach batteries. Many coaches do have that switch and I believe that is the only thing common - other than wiring to the batteries. You might want to check also if the batteries will accept a charge from a battery charger to determine if they are good or not. All of the above assumes that you have done reasonable battery maintenance such as water and assuring the connections to the batteries are not coroded.
__________________
2004 Itasca Sunrise 36', Workhorse
2003 Suzuki XL7
Dsouthw524 is offline   Reply With Quote
Old 10-22-2006, 11:50 AM   #7
Moderator Emeritus
 
Gary RVRoamer's Avatar


 
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 18,060
It sounds as though your converter/charger is not operating - that's what charges your batteries from either shore power or genset. It is usually plugged into a regular 120VAC outlet in the bay, so make sure that outlet has power (e.g. circuit breaker tripped). If that's OK, then likely the converter itself is not functionng. It probably has a fuse on its charging output circuit and that may have blown. Look on the converter itself for the fuse. Last & worst possibility is thatit has failed and will need to be replaced.

I'm assumming your battery disconect switch is in the on position becasue youwould have no 12V power to anything if it were not. No doubt you would have noticed that!
__________________
Gary Brinck
Former owner of 2004 American Tradition
Home is in the Ocala Nat'l Forest near Ocala, FL
Summers in Black Mountain, NC
Gary RVRoamer is offline   Reply With Quote
Old 10-22-2006, 12:01 PM   #8
JRP
Member
 
Join Date: Jun 2005
Location: SD, NM
Posts: 97
Red,

this main electrical switching system is one that each Mfg has their own different arrangement. you didn't give us any specifics or details about the rest of your primary electrical system.
other than whats already been mentioned, the potential componentents that are part of the 120 vac shore power and generator sources, but not part of your 12vdc engine alternator charging are:
the main transfer switch, the main 120vac breakers, the solenoid/relay and associated control board used by many mfg to isolate/parallel your two battery banks under charging conditions. (and bad connections at all those locations)

Jim
__________________
JRP is offline   Reply With Quote
Old 11-21-2006, 08:59 AM   #9
Senior Member
 
Country Coach Owners Club
Join Date: Jan 2006
Location: Redding
Posts: 3,412
I have a 300A fuse block between the charger and the batteries. It has failed and shown the sypmtoms you describe.

Mine is located in the battery compartment.
__________________

__________________
Dean
1995 CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
deandec is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Batteries and charging GraciesMom Class A Motorhome Discussions 6 11-05-2008 02:46 PM
Generator Running But Not Charging Batteries trailerware MH-General Discussions & Problems 19 05-31-2008 06:39 AM
Lost electric to outside outlet FloridaAnn National RV Owner's Forum 16 01-27-2008 08:34 PM
Batteries not charging Jimbo8264 MH-General Discussions & Problems 2 06-27-2007 09:08 AM
Generator Running But Not Charging Batteries Fleetwood Products Owner's Forum 19 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:28 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.