Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-01-2010, 12:05 PM   #1
Member
 
Bill Senick's Avatar
 
Join Date: Feb 2000
Location: Oxford, Florida, U.S.A.
Posts: 46
Generator Problems

Had a problem with my generator (Generac QuitePact 65 Gas) operating at 3/4 loads and above. Sent to dealer who changed fluids, filters and tune-up (plugs) after service I had the chance to run the generator at heavy loads and although it ran better than before I still was unable to run both roof airs.

After checking what was serviced I removed the plugs and found one was not firing at all, had plug out of engine with spark plug wire attached and no spark no shock. Anyone know what the problem is, I will not return to the servicing dealer but I also want to make sure where I do take it they are truthful. Thank you for any assistance.

Bill Senick
2003 Kountry Star KSCA 3740
__________________

__________________
Bill Senick is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-01-2010, 02:05 PM   #2
Member
 
squeak's Avatar
 
Join Date: May 2009
Location: Parker Az
Posts: 99
is it a bad plug? did you try swaping plugs? is the wire bad how about the coil is is the wire in it you can do a lot before taking it in just need to DIG IN and look
__________________

__________________
squeak is offline   Reply With Quote
Old 07-01-2010, 04:02 PM   #3
Senior Member
 
Join Date: Mar 2010
Posts: 124
Generator problem

Bill - Generac has a service bulletin on defective ignition coils on earlier 5500 and 6500 watt gensets -you have already checked for spark and found nothing on that plug wire (double check with another plug -you can use any type of new plug for this) - do not have the bulletin to post but replacing the coils requires removing the genset form the RV - you did not mention what year your RV is but if it's still under warranty then check for a Generac dealer near you ( did you take your coach to an RV dealer for service ?) - if it is the coil(s) then check with Generac- if you have to remove the genset from the RV see if you can get the work done under waranty if possible- let us know what happens.
__________________
RV Mech Tech is offline   Reply With Quote
Old 07-01-2010, 04:14 PM   #4
Member
 
Bill Senick's Avatar
 
Join Date: Feb 2000
Location: Oxford, Florida, U.S.A.
Posts: 46
RV Tech - No power to the one spark plug, does the Generac have two coils one for each cylinder. Thanks, Bill.
__________________
Bill Senick is offline   Reply With Quote
Old 07-01-2010, 04:23 PM   #5
Senior Member


 
Join Date: Nov 2009
Location: Big Bear Ca.(Sugarloaf)
Posts: 1,223
Did you ground the plug while checking spark?
__________________
Mark & Carole
What a long strange trip it's been.

No longer RVing. Happy Trails to you.
Campingman is offline   Reply With Quote
Old 07-01-2010, 04:41 PM   #6
Senior Member
 
Join Date: Mar 2010
Posts: 124
Generator problem

Bill -yes -one for each plug - if your RV is out of warranty an RV dealer may or may not be able to get a warranty coverage for you if this is the problem -a Generac dealer may be able to - you can check the Generac website for a dealer search for the nearest service center near you.
__________________
RV Mech Tech is offline   Reply With Quote
Old 07-01-2010, 10:37 PM   #7
Member
 
Bill Senick's Avatar
 
Join Date: Feb 2000
Location: Oxford, Florida, U.S.A.
Posts: 46
RV Tech - Thanks, will have dealer look at it, unfortunate that unit has to be pulled out, oh well!!!!

Thanks, Bill Senick
__________________
Bill Senick is offline   Reply With Quote
Old 07-01-2010, 11:39 PM   #8
Senior Member
 
Join Date: Mar 2010
Posts: 124
Generator problems

Bill - yes unfortunately the generator has to come out and the case sheet metal and the engine top sheet metal has to be pulled off to expose the flywheel and coils- the rare exception to this is if you have one of the smaller single cylinder generators and a large compartment that has enough room to pull the covers off - this is a magneto induction system and the coils have integral ignition modules in them and the early ones (modules) were failing - Generac has a replacement kit and you replace both coils not just one- I did a few of these under warranty in 2009- the coils are mounted next to the flywheel and easily replaced- getting to them is the hard part - you can see the service manual on www.generator-parts.com - go to the service manual section and its the first one -"OHV1 V-Twin Engine Service Manual for Models GTV 990/760 - click on the ignition link and you will see the pictures- let us know how everything turns out.
__________________
RV Mech Tech is offline   Reply With Quote
Old 07-02-2010, 10:03 AM   #9
JC2
Senior Member
 
JC2's Avatar
 
Newmar Owners Club
Texas Boomers Club
Join Date: Dec 2003
Location: Mo/Texas
Posts: 3,156
Quote:
Originally Posted by Bill Senick View Post
Had a problem with my generator (Generac QuitePact 65 Gas) operating at 3/4 loads and above. Sent to dealer who changed fluids, filters and tune-up (plugs) after service I had the chance to run the generator at heavy loads and although it ran better than before I still was unable to run both roof airs.

After checking what was serviced I removed the plugs and found one was not firing at all, had plug out of engine with spark plug wire attached and no spark no shock. Anyone know what the problem is, I will not return to the servicing dealer but I also want to make sure where I do take it they are truthful. Thank you for any assistance.

Bill Senick
2003 Kountry Star KSCA 3740

If you received less than stellar service from the gennie dealer, you might go to this site and fill out a service review so others will know to avoid.
RV Service Review
__________________

__________________
04 Newmar DSDP 4015-Cummins ISL 370hp-Spartan MM Chassis-2013 Chev Equinox AWD-Ready Brute Elite Towing System-FMCA 402879-SKP 120487
JC2 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:24 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.