Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 08-10-2010, 06:15 AM   #1
Junior Member
Join Date: Aug 2010
Posts: 1
Horn does not work

Need help concerning horn problem. The horn on my 2005 Workhorse chassis won't work. The 20 amp fuse, 50 amp fuse and horn relay all test ok. I have also taken the horn switch on the steering wheel apart and it seems OK. Anyone can help please...

Thank you

gabali is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-10-2010, 08:45 AM   #2
Senior Member
Possum's Avatar

Winnebago Owners Club
Vintage RV Owners Club
Join Date: Apr 2010
Location: Cherry Creek, BC Canada
Posts: 7,001
It may be a false lead but I just repaired a similar problem on an older MH and it was the leads in the wiring harness which were slightly corroded. The fix was simple and involved replacing one set of male/female spade wiring connectors and cleaning the connectors on the horns themselves. When from none to full set working in about and hours time.
Denise and Dennis Dalla-Vicenza Co-pilot Mizzie
Gracie a Winnebago 29 RQ +
George a Suzuki Toad
(Co-pilots emeritus Furb, Izzy & Mikkael)
Cherry Creek British Columbia
Possum is online now   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
So, your icemaker doesn't work! Jim Stewart Monaco Owner's Forum 17 11-28-2010 08:04 AM
Warranty work?????? RonK Fleetwood Products Owner's Forum 11 03-24-2009 04:24 AM
Indianapolis Motor Speedway Work Camp K6TBC Workkamping & Volunteering 1 11-12-2007 07:23 PM
warranty/repair svc work questionable ladyrvr66 Monaco Owner's Forum 11 03-15-2007 04:54 PM
Horn will not work prsmith Ford Motorhome Chassis Forum 2 08-28-2006 09:58 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:23 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.