Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-13-2011, 03:15 AM   #1
Senior Member
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Aug 2006
Posts: 1,500
HWH 325 Series System Quit

"It just goes to show you it is always something...." Rose Ann Rose Anna Danna

I had a hydraulic leak under my coach. Traced it to the distribution block of the levels/slide hydraulic. Tightened the brass hex head bolts (4). Seemed to work a couple of days. Leak started again. Traveled to new location. Watch as SWMBO operated the jacks. Saw leak at one of the aforementioned check valve bolts. Watched as she did slides. Pencil size stream came out. Had appointment for new tires. Got slides in and jacks up by catching fluid in a rag as she operated them.

Returned back to site (with six new tires) and went ahead and replaced "o" ring where leak seemed to originate. It was definitely bad, split. Checked other three and replaced one other for good measure. Was very careful not to allow dirt debris etc to enter the hole while bolt was out for replacement. Had DW activate jacks while I watched for leaks. She said she got not indication of jack being deployed. Checked fluid level. Added three quarts of hydraulic (ATF) fluid. Try again. Pump runs, panel and control box lights come on but no jack(s) down. Had her try bedroom slide and it got 1/2 way out and quit. Now no more in or out. No jacks.

Have an e mail into HWH will call them in the a.m.

Any suggestions, tips, pointers, or ideas?

All will be appreciated.
__________________

__________________
MaverickBBD is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-13-2011, 06:51 AM   #2
paz
Senior Member
 
paz's Avatar
 
Join Date: May 2005
Location: Full-timers - Home is where we park it.
Posts: 4,716
When my jacks quit several years ago (pump ran, but no jack extension), it was the shuttle valve. On the other hand, it could just be air in the lines since you were so low on hydraulic fluid. I think the system is self-purging, but I also think there is a procedure for manual purging. Hopefully, HWH will be able to help.

BTW, what kind of O-rings did you use? Were they Viton?

Let us know what happens.
__________________

__________________
2015 DRV Tradition 375KPS
2015 Chevy Duramax 3500HD LTZ Dually
Full-timers...Home is where we park it.
Check out our blog: Living Our Dream
paz is offline   Reply With Quote
Old 09-13-2011, 01:22 PM   #3
Senior Member
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Aug 2006
Posts: 1,500
I am hoping it is air in the system. Heading out to the only Master certified HWH service center in Oregon tomorrow. Will continue to cycle. As for the "o" rings, they are Eaton 7629X5, P/N 7629X5. I told the clerk at NAPA that they were for hydraulic service and he assured me these were the correct "o" rings but we know how that goes. I specifically mentioned viton. Anyway I got a mess of them, just in case.
__________________
MaverickBBD is offline   Reply With Quote
Reply

Tags
hwh



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HWH Series 310 Problems kstateaddict Winnebago Industries Owner's Forum 3 05-01-2011 08:54 AM
Hwh 625 leveling system bigfish Alpine Coach Owner's Forum 3 11-07-2009 11:40 AM
HWH air leveling system JVR Newmar Owner's Forum 5 05-15-2009 08:12 AM
HWH leveling system not working cabin Newmar Owner's Forum 8 05-09-2009 08:57 AM
Adding Active Air Ride to HWH System Jetsmania Newmar Owner's Forum 21 04-08-2007 05:13 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:24 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.