Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 09-30-2010, 04:42 PM   #1
Junior Member
Join Date: Sep 2010
Posts: 2
Question Kwikee Level Best 2000

New member, first post.

I have purchased a 1999 Coachman Catalina 322QB that has a Kwikee Level Best 2000 system. The jacks did not work when I purchased the motorhome. The "ALL UP" light was not green, previous owner told me that the right front jack had to be re-welded to the frame in the past but the system was working when he traded it in.

I removed the reed switch on the right front jack and ran it to ground. "ALL UP" went to green. Using the control panel no jacks will move, pump never runs. I jumpered across the solenoid and the jacks work fine. Replaced the solenoid and still the same, ran a separate ground wire for the solenoid no change. I have removed the phone wire from the control panel to do a reset, no change.

Looking for troubleshooting advice.

ceejayebg is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-30-2010, 10:54 PM   #2
Senior Member
LVJ58's Avatar
Join Date: Jul 2000
Location: Las Vegas, NV
Posts: 1,999
If your control module for the system is attached to the pump reservoir, you have an early model unit. I had a problem with my K-2000 levelers and Kwikee sent me a new panel with the control module built in. Your problem could be a bad control module that may need replacing..just a thought

Jim & SherrySeward

2000 Residency 3790 v10 w/tags 5 Star tune & Banks system Suzuki XL7 toad
LVJ58 is offline   Reply With Quote
Old 10-02-2010, 07:11 AM   #3
Junior Member
Join Date: Sep 2010
Posts: 2
Thanks for the reply, and yes the control module is part of the pump. I will contact Kwikee.
ceejayebg is offline   Reply With Quote
Old 10-02-2010, 11:56 AM   #4
Senior Member
Workhorse Chassis Owner
Join Date: Jun 2003
Location: Palisade CO
Posts: 3,395
Unless things have changed in the last month or so, actually you probably won't contact them.
They used to have decent customer service but since being bought by Actuant their customer service is nonexistent. Even dealers are complaining about calls not being returned.
There is some troubleshooting info on their web site that might be helpful though.
Kwikee Products - Literature
Clay WA5NMR - Ex Snowbird - 1 year, Ex Full timer for 11 years - 2004 Winnebago Sightseer 35N Workhorse chassis. Honda Accord toad.
Clay L is offline   Reply With Quote

kwikee, kwikee levelbest 2000

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 intrigue air leveler benchrest Country Coach Owners Forum 3 08-31-2010 01:56 PM
Out of level Refridgerator Woolfy Winnebago Industries Owner's Forum 12 12-02-2008 08:24 AM
Allison 1000 and 2000 S/N6310001000 and S/N6310203136 rednlh Workhorse and Chevrolet Chassis Motorhome Forum 3 07-01-2007 11:01 AM
34CKNext Level with '05 Dodge 2500 4x4 SB CTD, ok ??? twvette Toy Haulers Discussion 9 09-07-2005 02:16 PM
Oil level 05 Journey with 350 Cat Wolf S Winnebago Industries Owner's Forum 4 08-23-2005 04:01 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:42 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.