Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-16-2005, 11:08 AM   #1
Member
 
cboh1's Avatar
 
Join Date: Apr 2005
Location: Southern CALIF.
Posts: 89
Hello,
__________________

__________________
2005 Ford F-250 FX4 PSD Crew Cab

2004 Jeep Wrangler 4X4
cboh1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-16-2005, 11:08 AM   #2
Member
 
cboh1's Avatar
 
Join Date: Apr 2005
Location: Southern CALIF.
Posts: 89
Hello,
__________________

__________________
2005 Ford F-250 FX4 PSD Crew Cab

2004 Jeep Wrangler 4X4
cboh1 is offline   Reply With Quote
Old 04-16-2005, 11:45 AM   #3
Senior Member
 
Logthumper's Avatar
 
Monaco Owners Club
Join Date: Jul 2000
Location: Shawnee, Kansas
Posts: 388
Most likely the Engine light looking at the fuel tank. Make sure the fuel tank cap is on tight. Then reset as you did befor and see if the light stays out. A hand held code reader is handy to get a code readout so that you know for sure what set the light off. Your dealer can read the code for you. No big thing, but its nice to know why its comming on.
__________________
Monaco Knight PDQ38,2007
RR8R Chassis, ISC330 Cummins
Logthumper is offline   Reply With Quote
Old 04-16-2005, 05:39 PM   #4
Moderator Emeritus
 
Cruzer's Avatar


 
Join Date: Oct 2002
Location: Sheboygan, WI
Posts: 4,900
I had the same with my 33V/W20 and it ran well also. The Workhorse dealership found a connector on the wiring harness that hadn't been fully seated. Check the wiring harness connectors. If anything is loose, push them in until they go "click". It may be that simple.
__________________
Mark & Leann Quasius
2016 Cornerstone 45A
2007 Allegro Bus 42QRP (Sold)
2012 Jeep Wrangler Unlimited - Rubicon
Cruzer is offline   Reply With Quote
Old 04-17-2005, 08:59 AM   #5
Senior Member
 
Join Date: Mar 2005
Location: North Carolina
Posts: 109
My suggestion- take it to the Workhorse repair center and have the exhaust fixed. When that's done have them crank it up & let it run awhile. If the engine light continues to come on tell them to keep it till they fix it.

Good luck,
Dave
__________________
2006 Fleetwood Excursion 39L

Spartan & 350 CAT
Catdave is offline   Reply With Quote
Old 04-17-2005, 03:01 PM   #6
Senior Member
 
Join Date: Mar 2005
Location: North Carolina
Posts: 109
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by cboh1:
Thanks Cat Dave,

This little light issue made me think and compile a list of all the things wrong on our new 2005 Adventurer 33V. Ended up with 35 items.From water leaks in the slide outs to brake issues. </div></BLOCKQUOTE>

Sorry to hear you've got those problems, cboh1. Don't let it spoil your new RV experience though. Let the dealer fix the discreps and motor on down the road!

Best of luck,
Dave
__________________
2006 Fleetwood Excursion 39L

Spartan & 350 CAT
Catdave is offline   Reply With Quote
Old 04-18-2005, 07:27 AM   #7
Member
 
Join Date: Nov 2003
Location: Lauderdale, Ms, USA
Posts: 42
cboh1
Just a thought and may not be the problem. I had the same thing happen to me a year or so ago. Engine light came on and I checked everything, decided to add a little oil and after about 1/2 quart added it went off and never had the problem again. I think it was after I did an oil change and used the longer filter and just didn't quite reach the mark.
Good luck
Cris
__________________
02 Itasca/SC/35U/W/H
04 Vue/BB/B/Ox
criscriscola is offline   Reply With Quote
Old 04-20-2005, 09:10 AM   #8
Senior Member
 
Join Date: Jul 2003
Location: Commerce Twp, MI
Posts: 309
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by cboh1:
I did change over the fuel cap to locking but it was a direct change over ... </div></BLOCKQUOTE>

Where did you get a locking fuel cap for the W22?
__________________

__________________
2012 Winnebago Adventurer 35P, Roadmaster F+R sway bars, Blue Ox Tiger Trac, 06 HHR toad
past:2003 Itasca Suncruiser 38G
LandHo is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Powerline EMS - Water heater light will not light rv rick Winnebago Industries Owner's Forum 9 10-14-2008 04:20 PM
Tail light / Brake light issue... Richard 34A Winnebago Industries Owner's Forum 8 07-15-2008 06:59 AM
Ford Transmission Control Indicator Light and check engine light HKB MH-General Discussions & Problems 4 05-28-2007 04:23 PM
Brake Light Switch/ABS Light Golden Gopher Workhorse and Chevrolet Chassis Motorhome Forum 6 08-22-2006 10:01 PM
ABS LIGHT and Low BRAKE Fluid LIGHT M&EM Workhorse and Chevrolet Chassis Motorhome Forum 6 01-12-2005 02:15 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:57 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.