Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-23-2012, 04:35 PM   #1
Senior Member
 
Dakrism's Avatar


 
Monaco Owners Club
Join Date: Sep 2012
Location: Cicero In
Posts: 202
Newly battery question

Looking at my battery status if I am on 30 amp shore power should I be charging my batteries? My panel just shows a half charge.
Also does anyone know what The white switch looking thing is ?
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	85
Size:	293.0 KB
ID:	30869  
__________________

__________________
Dan & Kris Murphy

2009 Beaver Contessa
2015 Ford Edge SEL
Dakrism is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-23-2012, 04:55 PM   #2
Moderator Emeritus
 
RickO's Avatar


 
Join Date: Jan 2007
Location: Litchfield Park, Arizona
Posts: 10,530
Yes, you should be charging your house batteries when plugged in to nearly all shore power connections. Are you saying that your batteries never register above half charge even after being plugged in to shore power for a while?

I'd take a volt meter and measure the battery voltage when disconnected... you'll probably see around 12.8v when fully charged. Then plug in to shore power and measure again. I'd expect the voltage measured at the battery terminals to be at least 13.6v indicating that the charger was charging.

I'm sure some of our Tiffin experts will be along soon to chime in.

Best of luck.

Rick
__________________

__________________
Rick, Nancy, Peanut & Lola our Westie Dogs & Bailey the Sheltie.

2007 Itasca Ellipse 40FD
RickO is offline   Reply With Quote
Old 12-23-2012, 05:01 PM   #3
Member
 
sailorbowman's Avatar
 
Winnebago Owners Club
Workhorse Chassis Owner
Join Date: Aug 2010
Posts: 39
Great picture! You certainly seem to have read the xantrex display correctly. The voltage is 14 dc and should be charging your battery(s). You did not post how long the MH was pluged to shore power when the picture was captured.
1. The battery(s) are still charging...give it some more time.
2. The battery(s) are of questionable durability. (amp storage capacity)
3. The battery(s) terminals are dirty or have poor connections, or have poor cables.

There could be other issues going on here, but these are the easiest to begin checking.
The white switch is a good question. No label. No idea. Hate it when that happens.
__________________
2002 Winnebago Adventurer 32
Workhorse 8.1 Liter Allison Trans
Liberty Toad
sailorbowman is offline   Reply With Quote
Old 12-23-2012, 05:14 PM   #4
YC1
Senior Member
 
YC1's Avatar


 
Holiday Rambler Owners Club
Join Date: Jun 2011
Posts: 5,565
You charger is indeed working. The ten amps showing seems a bit low but definitely charging. It could take over night for the idiot light to go to the full mode. However, without looking at the manual is there a way to adjust the charger rate?

As for the little white panel. You have a satellite dish on the roof. If you push the button and then raise the dish you should see the elevation readout. I won't go into details but just 1/2 of a turn up and down will lose or acquire a satellite. You have more grace right and left. You can turn a couple of inches to each side and still get a signal. Once you get your satellite tweaked up, crank the handle down and count the turns. Even a 1/2 turn for future reference.

If the plate does not light up, pop it off and look for a battery. I had one many years ago and it ate batteries. I added a simple push button switch that activated the battery only while the button was pushed.

Back to the charger meter. Turn as many lights on as possible and check the voltage and current. Your voltage should hold well. If not as suggested you probably need to do some battery cable maintenace. Use safety goggles when you do.
__________________
Myron & Deborah
08 HR Endeavor 40 SKQ
2012 Ford Edge Limited FWD 3.5L
Aluminator tow bar, Demco base plate
YC1 is online now   Reply With Quote
Old 12-23-2012, 05:19 PM   #5
Senior Member
 
wa8yxm's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 22,792
I can think of several things, What happens when you push it....

There is a type of Sat Antenna (manual) that uses a display much like that to indicate the elevation Or a voltmeter.
__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 12-23-2012, 06:12 PM   #6
Senior Member
 
Dakrism's Avatar


 
Monaco Owners Club
Join Date: Sep 2012
Location: Cicero In
Posts: 202
We just brought the coach home and have had it plugged in all day.I will check in the morning to see if I have obtained a full charge. I am just not sure how this should all work. The coach does have a Tracstar Sat system but it is not hooked up.So this white switch could be for the Sat system? I will have to find out how to use the system.
__________________
Dan & Kris Murphy

2009 Beaver Contessa
2015 Ford Edge SEL
Dakrism is offline   Reply With Quote
Old 12-23-2012, 06:40 PM   #7
Moderator Emeritus
 
RickO's Avatar


 
Join Date: Jan 2007
Location: Litchfield Park, Arizona
Posts: 10,530
Quote:
Originally Posted by Dakrism View Post
We just brought the coach home and have had it plugged in all day.I will check in the morning to see if I have obtained a full charge. I am just not sure how this should all work. The coach does have a Tracstar Sat system but it is not hooked up.So this white switch could be for the Sat system? I will have to find out how to use the system.
Have you used the 30amp connection at your home for RV hook ups before?

Rick
__________________
Rick, Nancy, Peanut & Lola our Westie Dogs & Bailey the Sheltie.

2007 Itasca Ellipse 40FD
RickO is offline   Reply With Quote
Old 12-23-2012, 07:04 PM   #8
Senior Member
 
Dakrism's Avatar


 
Monaco Owners Club
Join Date: Sep 2012
Location: Cicero In
Posts: 202
Rick
I just put the 30 amp circuit in last week. We did Install a TT 30 amp Rv outlet so I'm pretty sure we have a good 30 amp connection.we did run the slides in and out a couple times last nite. I just thought the batteries should show a full charge by now.
If I don't have a full charge in the morning should I start the generator?
__________________
Dan & Kris Murphy

2009 Beaver Contessa
2015 Ford Edge SEL
Dakrism is offline   Reply With Quote
Old 12-23-2012, 07:07 PM   #9
Moderator Emeritus
 
RickO's Avatar


 
Join Date: Jan 2007
Location: Litchfield Park, Arizona
Posts: 10,530
Quote:
Originally Posted by Dakrism View Post
Rick
I just put the 30 amp circuit in last week. We did Install a TT 30 amp Rv outlet so I'm pretty sure we have a good 30 amp connection.we did run the slides in and out a couple times last nite. I just thought the batteries should show a full charge by now.
If I don't have a full charge in the morning should I start the generator?
Thanks. I just wanted to cover all the bases.

If they don't show a full charge by morning, I'm not sure starting the gennie will tell you anything since I believe it just supplies AC power to your inverter and I doubt you'd see any change.

Rick
__________________
Rick, Nancy, Peanut & Lola our Westie Dogs & Bailey the Sheltie.

2007 Itasca Ellipse 40FD
RickO is offline   Reply With Quote
Old 12-23-2012, 07:35 PM   #10
Senior Member
 
Dakrism's Avatar


 
Monaco Owners Club
Join Date: Sep 2012
Location: Cicero In
Posts: 202
Thanks Rick. I will see what the panel says in the morning and then go from there.there are just so many things to learn about. I will read about the inverter tonite.
__________________
Dan & Kris Murphy

2009 Beaver Contessa
2015 Ford Edge SEL
Dakrism is offline   Reply With Quote
Old 12-23-2012, 08:19 PM   #11
Senior Member
 
vsheetz's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Jun 2012
Location: SoCal
Posts: 11,789
Have you checked the water level in the batteries?
__________________
Vince and Susan
2011 Tiffin Phaeton 40QTH (Cummins ISC/Freightliner)
Flat towing a modified 2005 Jeep (Rubicon Wrangler)
Previously a 2002 Fleetwood Pace Arrow 37A and a 1995 Safari Trek 2830.
vsheetz is offline   Reply With Quote
Old 12-23-2012, 08:24 PM   #12
Senior Member
 
Dakrism's Avatar


 
Monaco Owners Club
Join Date: Sep 2012
Location: Cicero In
Posts: 202
Vince
The mechanic showed me how to add water and I just assumed they are ok.the batteries are new.
__________________
Dan & Kris Murphy

2009 Beaver Contessa
2015 Ford Edge SEL
Dakrism is offline   Reply With Quote
Old 12-23-2012, 09:01 PM   #13
Senior Member
 
Frutza's Avatar
 
Gulf Streamers Club
Freightliner Owners Club
Join Date: Dec 2011
Location: Crown Point, In
Posts: 304
I could be wrong, but isnt there supposed to be an led light in the button that says"charge"? you have ac in but is the charger turned on? you should have a light on the main unit to verify this also, Is the dc amp side of your display, charging amps or out going amps, like dc being used by the coach, 200 amp charger is a big charger, not sure, just a thought? Good luck, oh HAPPY HOLIDAYS
__________________
Mike & Becky
2005 Gulfstream Crescendo 8356
Frutza is offline   Reply With Quote
Old 12-23-2012, 09:07 PM   #14
Senior Member
 
Dakrism's Avatar


 
Monaco Owners Club
Join Date: Sep 2012
Location: Cicero In
Posts: 202
Mike,
Do you mean I need to turn a charger on somewhere other than this control panel in my photo?
There ia an led lite on the button on the control panel
__________________

__________________
Dan & Kris Murphy

2009 Beaver Contessa
2015 Ford Edge SEL
Dakrism is offline   Reply With Quote
Reply

Tags
battery



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:17 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.