Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-17-2009, 06:23 PM   #1
Junior Member
 
Join Date: Aug 2009
Posts: 4
Newmar Dutch Star-3126 Cat Electrical Issue

I have a 2001 Dutch Star with a 3126 Cat in it. Recently I have had a recurring issue of all the gauges on the dash going dead and the idiot warning lights flashing in a counter-clockwise pattern. There is no change in performance. To reset the dash, I have pulled to a safe location and simply set the air brake which seems to reset everything. It is an intermittent problem. I checked grounds and power supply to the dash fuse block. I really havent had a chance to investigate it much more. Does anyone have any ideas or similar instances of trouble?

Thanks, Gary
__________________

__________________
waybuzd is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-17-2009, 09:07 PM   #2
Senior Member
 
Join Date: Jul 2007
Posts: 225
Waybuzd, I've had issues with erratic readings on my air pressure gauges (bad solder joints in the VDO), but nothing effecting the other gauges or warning lights as you describe. I agree it sounds like a bad ground somewhere and I'd continue looking in that direction.
__________________

__________________

2017 Eagle HT 27.5 RLTS
2011 Chevy 2500HD Duramax Crew Cab 4WD
REWahoo is offline   Reply With Quote
Old 08-17-2009, 10:32 PM   #3
Junior Member
 
Join Date: Aug 2009
Posts: 4
Thanks...I hate electrical problems.
__________________
waybuzd is offline   Reply With Quote
Old 08-18-2009, 03:41 AM   #4
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
waybuzd, welcome to iRV2.com. We are glad to have you join us here.
If you have not checked the main ground cables, I would suggest you do. Check at the battery bank, frame, transmission and motor. You can always add a new ground as you cannot have too many. After that, make certain the ignition switch connection is good and that you do not have a big heavy wad of keys hanging on the ignition key. Good luck and keep us posted.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 08-19-2009, 09:26 PM   #5
Senior Member
 
Join Date: Nov 2003
Location: Richmond Hill, GA USA
Posts: 671
The condition of "the idiot warning lights flashing in a counter-clockwise pattern." is indicative of low voltage. Besides checking grounds, etc as posted above, it might be worthwhile to check alternator output.
__________________
Fred & Vicki
St. Augustine, Fl.
Fred Cooper is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dutch Star electrical problem SNAIL1 Newmar Owner's Forum 5 10-24-2008 07:57 AM
2009 Dutch Star CLM Newmar Owner's Forum 2 04-08-2008 11:04 AM
2008 Dutch Star or 2009 Dutch Aire Branden Newmar Owner's Forum 13 03-29-2008 12:39 PM
07 Dutch Star Wiper Problem dolsen58 Newmar Owner's Forum 25 09-05-2007 05:13 AM
Alpine VS Allegro Bus VS Newmar Kountry Star redeldo Alpine Coach Owner's Forum 8 12-19-2006 02:03 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.