Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 11-10-2014, 07:29 AM   #15
Junior Member
Join Date: Oct 2014
Posts: 17
I tried everything I could think of with no luck. There is one other outlet inside that doesn't work. I did find, however, that whew when I stick a multimeter either non working outlet, with the ground in the ground hole, I'm seeing around 40v...???????

Dave Chabot
Coventry, RI
"Life's so short...don't waste it!"
chefdc1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-10-2014, 08:32 AM   #16
Moderator Emeritus
Gary RVRoamer's Avatar

Fleetwood Owners Club
Freightliner Owners Club
Join Date: Jan 2000
Location: Silver Springs, FL. USA
Posts: 16,446
If the breaker is fine but the outlet produces no power then one good possibility is that the neutral wire at the outlet is broken. Only the "hot' wire goes through the breaker. Check the power between the hot wire and the ground (not neutral) at the outlet. If that shows 120v, then the neutral is the problem. If it does not, then the 120v is not getting to the outlet from the breaker and you may have a defective hot wire.

I doubt if a 1997 Damon has an inverter unless somebody added one afterwards. It did not originally have one - just a converter/charger for 12v.

Gary Brinck
2004 American Tradition; 2014 Buick LaCRosse
Homebase in the Ocala Nat'l Forest near Ocala, FL
Gary RVRoamer is offline   Reply With Quote
Old 11-10-2014, 09:19 PM   #17
Senior Member
Dave Fernandez's Avatar
Alpine Owners Club
Join Date: Jun 2003
Location: Ontario, CA USA
Posts: 1,241
The outlet may only one in a series. So the problem may be at another outlet in the series. This was just to help with Ideas in finding the problem.

Let us know what you find.
Dave Fernandez
2001, 38ft FDDS, 350 ISC, Tow 2004 Yukon
Dave Fernandez is online now   Reply With Quote
Old 02-22-2015, 09:09 AM   #18
Junior Member
Join Date: May 2013
Posts: 2
May be late on this but I had the same problem. I found out it was a bad connection inside of a receptacle. the breaker checked good as well as the first two receptacles in the circuit but when I pulled the third receptacles (head of the bed at floor level) the wire had come out of the crimp. I replace these three receptacles with better quality (screw terminal connections) and solved the problem. I will be replacing all the duplex receptacles and boxes before spring.

Richard3529 is offline   Reply With Quote

fridge, power

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Update on my Residential Fridge Retrofit Gadget Man RV Systems & Appliances 11 12-03-2014 06:34 PM
Power inverter issues BigDBright RV Systems & Appliances 6 09-27-2014 06:56 PM
Generator power problem. AttilaKara72 Monaco Owner's Forum 1 09-07-2014 08:34 AM
Jensen JRV212T Radio/Monitor power Butte64 Technology: Internet, TV, Satellite, Cell Phones, etc. 0 09-01-2014 07:11 AM
Pedestal or MH Power Problem sgtjoe National RV Owner's Forum 32 02-19-2014 06:47 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:17 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.