Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 12-27-2010, 08:56 PM   #1
Senior Member
Winnebago Owners Club
Workhorse Chassis Owner
Join Date: Jun 2006
Location: SO. CA.
Posts: 169
No power to outlets in coach

Has anyone experienced no power to the inside outlets in the coach including the front Television and Microwave?
I checked all the breakers inside the door of the coach and all were set.
Could it be the main breakers under the step by the batteries?
I have a 2004 Winnebago Adventurer.
Thanks in advance for any help you can give me.


2004 Adventurer 33' W20 03Chassis, 4 Koni's, Ultrapower/Taylor Wires
BobD is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-27-2010, 09:11 PM   #2
Moderator Emeritus
RickO's Avatar

Join Date: Jan 2007
Location: Litchfield Park, Arizona
Posts: 10,528
Hi Bob...

I'm not familiar with your particular coach but when all outlets are out it's usually pretty easy to find.

I think more information will help. Are you plugged in to shore power? 30 or 50 amp? Are you sure you're getting power from the pedistal? Are you using a surge protector? Do the outlets work under generator power?

I had this problem once and it turned out to be a breaker on or near the generator that had been somehow tripped.


Rick, Nancy, Peanut & Lola our Westie Dogs & Bailey the Sheltie.

2007 Itasca Ellipse 40FD
RickO is offline   Reply With Quote
Old 12-27-2010, 09:14 PM   #3
Senior Member
jacmat's Avatar
Monaco Owners Club
Join Date: Jun 2008
Location: Quebec, Canada
Posts: 145
It might be your GFI breaker that has tripped. Check in the bathroom or outside plugs and push on the reset.
Monaco Diplomat
jacmat is offline   Reply With Quote
Old 12-27-2010, 09:15 PM   #4
Senior Member
Join Date: Apr 2000
Location: Somewhere under a wandering star
Posts: 185
Check in the bathroom and kitchen area for your GFI. It is usually around the outlets by a sink. Or it may be on/in your main breaker panel.
1998 Volvo 610
2001 Alfa Ideal, 38.5, triple axle, triple slide
Jim Gehlen is offline   Reply With Quote
Old 12-27-2010, 09:23 PM   #5
Senior Member
Winnebago Owners Club
Workhorse Chassis Owner
Join Date: Jun 2006
Location: SO. CA.
Posts: 169
No power to outlets in coach

Thanks Rick, Jacmat and Jim for your responses so quickly.
It was the breaker near the generator that had tripped and now everything is back to normal.
We had not had the coach out for a while and this just happened.
Just for everyones information the problem was while we were running the generator.
Again my thanks to all of you for your help.

2004 Adventurer 33' W20 03Chassis, 4 Koni's, Ultrapower/Taylor Wires
BobD is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Gear Levelers fail to extend fully to level coach catrst MH-General Discussions & Problems 4 12-30-2010 05:29 AM
Stopping charging of coach battery while on shore power komac MH-General Discussions & Problems 17 10-24-2010 06:46 AM
No AC Power inside coach jwinqui Alpine Coach Owner's Forum 12 04-01-2010 04:53 PM
Lost Power To All Outlets Injun Joe MH-General Discussions & Problems 14 01-17-2010 08:18 AM
Power to coach without batteries?? Jack Foster Newmar Owner's Forum 4 12-22-2006 06:04 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:44 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.