Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 11-14-2014, 04:42 PM   #1
Junior Member
Join Date: Oct 2014
Posts: 11
No power to shifter pad

95 monaco signature my shifter pad is not lighting up when key is in the run position and my check trans light is on... Why is this and I am assuming this is a major probkem... Can anyone help me out here

cory0789 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-14-2014, 07:05 PM   #2
Senior Member
jacwjames's Avatar
Monaco Owners Club
Join Date: Jun 2014
Posts: 3,588
Yours is an older transmission the mine, I assume it is an Allison??

Does the motorhome start? Can you get any diagnostic codes off of the key pad.

On my 2002 Windsor the Allison has the ability to shut down if it senses a major problem. Mine dis this last year, the same symptom but the engine would not start. Turned out to be the ECU which had to be replaced for +$3K.

I could not get a service technician to come to the house to diagnose, had to have the coach towed. We did not have time to fool around so had them tow it and they sourced a new ECU that had to be programed based on the SN of our transmission.

If you have time the ECU's can be rebuilt (or at least on my model year they can be rebuilt). My ECU was located in the driver side front run bay. It is a plug and play unit.

Jim J
2002 Monaco Windsor 38 PKD
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is offline   Reply With Quote
Old 11-15-2014, 03:30 AM   #3
Senior Member
94-Newmar's Avatar
Join Date: Nov 2009
Posts: 2,043
Cory, in a previous double post last month, you had starting problems. I looked through both threads located here: 1995 Starting Problem and here: Starting Problem please Help

Many members here posted in an attempt to help you. Unfortunately, I do not see where you ever posted that you resolved your starting problem. Did you resolve it and now the transmission touchpad issue has occurred or are you still in a no-start situation?

Posting a picture of your transmission touchpad will certainly help figure out which controller you have and allow for better troubleshooting. There are 2 different manufacturers and 3 different transmission controllers that your unit could have - the troubleshooting process for each is entirely different.
94-Newmar Kountry Star 40-KSDP
Spartan/Cummins 8.3C-300HP/Allison 3060 WTEC-II/25yr RV Tech RVIA Certified/Onan-Cummins Certified
94-Newmar is offline   Reply With Quote
Old 11-19-2014, 08:04 PM   #4
Senior Member
Join Date: Apr 2005
Posts: 310
Cory, I have had the same issue with no power to Allison shift pad. Check my previous posts. There may be a fused wire at your chassis battery feeding your shifter. My fuse was fine, but a few feet forward was a butt connector that went bad. Several years later, another problem came up that was resolved with a rebuild of my ECM by Transmission Instruments in Texas, total satisfaction with that repair. Good luck, HarveyP
94 Holiday Rambler Endeavor LE

HarveyP is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Switching Power Sources on an 85 Mallard wolf_7669 Vintage RV's 4 10-28-2014 02:16 PM
Adding more power vs safety to engine Smitty77 Cummins Engines 15 10-13-2014 08:06 AM
No house power, mh newbie barber3827 MH-General Discussions & Problems 4 08-01-2014 11:25 PM
Automatic Power Switch Problem Zertman RV Systems & Appliances 12 07-07-2014 03:52 PM
2003.Discovery help no ignition power Alanboss Class A Motorhome Discussions 3 03-28-2014 06:05 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:40 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.