Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-31-2003, 04:44 PM   #1
Junior Member
 
Join Date: May 2003
Posts: 2
recently experienced a no start on motorhome. all dash gauges come on, all fuses are good. had just dumped air, leveled coach then after retracting jacks went to start and nothing. only items that are now not working are 1)allison trans. touch panel is not working (no lights indicating neutral) and 2) jacks down warning buzzer is now not working (jacks still work ok for extend and retract). have checked all relays under dash and visually inspected wire harness to rear for faults. Help.
__________________

__________________
shipwreck is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-31-2003, 04:44 PM   #2
Junior Member
 
Join Date: May 2003
Posts: 2
recently experienced a no start on motorhome. all dash gauges come on, all fuses are good. had just dumped air, leveled coach then after retracting jacks went to start and nothing. only items that are now not working are 1)allison trans. touch panel is not working (no lights indicating neutral) and 2) jacks down warning buzzer is now not working (jacks still work ok for extend and retract). have checked all relays under dash and visually inspected wire harness to rear for faults. Help.
__________________

__________________
shipwreck is offline   Reply With Quote
Old 06-01-2003, 08:31 AM   #3
doc
Senior Member
 
doc's Avatar
 
Appalachian Campers
Join Date: Sep 2002
Location: Dixie !! (north Georgia) USA
Posts: 2,955
battery OK? Parking brake pulled out like it should be? House batteries up? Did you try the MOM start?

Bet it is going to be something simple.

Welcome to the forum by the way. Good people here.
__________________
doc is offline   Reply With Quote
Old 06-01-2003, 11:43 AM   #4
Senior Member
 
Join Date: Apr 2000
Location: Crossville,TN USA
Posts: 437
shipwreck, you could check out www.discoveryowners.com, they have a lot of folks on there that could just about build you a Discovery, good luck, Ken Roberts, former Discovery owner, Littleton, MA...
__________________
Ken Roberts is offline   Reply With Quote
Old 06-01-2003, 12:59 PM   #5
Member
 
Join Date: Nov 2002
Location: Dubois, Wy, USA
Posts: 96
I had the exact same problem, but on a gas chassis. The parking brake light wire had fallen off of the switch on the parking brake. The levelers would not turn on and engine would not crank.

cad_man

Newmar 2003 Kountry Star
Workhorse W22 8.1l Allison
KSCA3301
FMCA F322927
KG6JIY
__________________
CAD-Man[/i]

CAD-Man is offline   Reply With Quote
Old 10-24-2006, 02:10 PM   #6
Junior Member
 
Join Date: Oct 2006
Posts: 1
What was the repair. I have the same problem. I have been stranded for two days and cannot find the problem to correct it.
__________________
Gerald Heard is offline   Reply With Quote
Old 10-24-2006, 07:41 PM   #7
Senior Member
 
Join Date: Apr 2005
Posts: 314
My Allison 3060 has a wire that feeds off chassis battery with a fuse very close to battery. Wire and fuse were good, but just behind battery was a butt connector that had gone bad. Out of sight until really hunting for it. Cost towing insurance $1000+ and cost me $200 + at Allison place. Good luck, HarveyP
__________________

__________________
94 Holiday Rambler Endeavor LE

Cummins/Allison
HarveyP is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fleetwood Discovery alternator problems boblew Fleetwood Products Owner's Forum 20 08-18-2011 02:41 PM
Difference between Discovery/Excusion by Fleetwood? tqracn Class A Motorhome Discussions 12 01-03-2009 08:25 AM
2008 Fleetwood Discovery Freightliner Chasis steering donrltr MH-General Discussions & Problems 9 03-14-2008 05:17 PM
towing limits on fleetwood discovery fredfarkle Toads and Motorhome Related Towing 11 03-02-2008 04:57 PM
towing limits on fleetwood discovery Fleetwood Products Owner's Forum 11 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:20 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.