Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-20-2011, 12:08 AM   #1
Junior Member
 
Join Date: May 2011
Posts: 1
Onan 5.5 KW gas no startup

My Onan 5.5 gas genset turns over at proper speed at both remote and on-unit rocker switch, but no start after 30 seconds of fuel priming by holding down bottom of rocker and wait for steady red LED. Started and ran fine one week ago. Gas tank is near full, so level sensor cutoff is probably not the problem. Suspect some operator oversight. Any ideas? Thanks...
2004 Fleetwood Southwind 32/Workhorse chassis
__________________

__________________
macgyvercam is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-20-2011, 03:48 AM   #2
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,062
Hello and . We are glad to have you join us here and we look forward to reading of your adventures and experiences. I am sure you will enjoy the website and forums. Good luck, stay safe and keep us posted.
Have you removed the fuel line from the carburetor, primed the unit and check to see if you get fuel out of the line? If so, then the problem will be in the carburetor. If not, then check the fuel filter and fuel lines for clog or possible pin hole in line. Let us know what you find.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Reply

Tags
fleetwood southwind, gas, onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Switching from elec to gas on water heater stotaman RV Systems & Appliances 3 10-18-2011 05:50 PM
Onan Marques 5500 gas fuel filter change Rambler1 MH-General Discussions & Problems 6 11-09-2010 08:48 AM
Onan Generator question Rick Flores MH-General Discussions & Problems 8 11-21-2009 10:17 PM
The Gas Station Design Conspiracy! RVThere RV'ing Humor & Crazy but True Stories 10 09-06-2008 01:01 PM
Onan Gas Generator won't start John Hilley Winnebago Industries Owner's Forum 3 12-03-2007 06:24 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:54 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.