Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-09-2009, 12:18 PM   #1
Senior Member
 
Vintage RV Owners Club
Gulf Streamers Club
Join Date: Mar 2009
Posts: 140
Onan 6.5 emerald series gen problem

Hi everyone! I have an older Onan Genset. It has about 300 hours on it.
When I firlst got the MH Geney would't keep running. So I troubleshot it
and found the control board to be bad. Replaced it with one from Flight
Systems and it started and ran flawlessly for about an hour under load.

With that being said, I hadn't started it for about a month as we are parked with shore power. We were about to take off for the 4th and wanted to make sure the gen was running so I tried to start it.

It cranked over a few times filled the fuel intake bowl then stopped cranking all together. Checked the batteries, (the coaches is brand new)
the house's showed full charge. but acted like a car when the battery is
low and all you get is the click click click at the solenoid. Cleaned the conectors, and now I am not getting but a single click at the solenoid.

Any suggestions?? Thanks in advance BJ
__________________

__________________
bjcarpetguy is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-09-2009, 10:08 PM   #2
Junior Member
 
art(alamoc)'s Avatar
 
Join Date: Jun 2009
Posts: 7
Use Jumper cables from a car to the Generator, red jumper clamp at the solenoid red lead and the black jumper clamp grounded to the frame. I used a Jump Start System box when I was having my gen. trouble.
__________________

__________________
art(alamoc) is offline   Reply With Quote
Old 07-09-2009, 11:34 PM   #3
Senior Member
 
Vintage RV Owners Club
Gulf Streamers Club
Join Date: Mar 2009
Posts: 140
I had used the jumper cables, as soon as I touched ground I started getting sparks.
pulled the starter and it looks as though the positive post on the starter had fried.
Ordered one today and hope that is the problem. I'll keep everyone posted.
Thanks BJ.
__________________
bjcarpetguy is offline   Reply With Quote
Old 07-10-2009, 09:01 AM   #4
Junior Member
 
art(alamoc)'s Avatar
 
Join Date: Jun 2009
Posts: 7
Be ready to removed the power when you connect back the positive post, something had to cause this short in the system.
__________________
art(alamoc) is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Magnadyne DVD Problem - Possible Fix Robin_M Monaco Owner's Forum 21 07-06-2009 08:58 PM
Onan 4BGE 4000 gen set mustang Winnebago Industries Owner's Forum 6 11-08-2008 07:15 AM
Onan problem Bill Fleming Alpine Coach Owner's Forum 3 05-29-2008 06:53 AM
Onan Gen! Latitude Newmar Owner's Forum 9 05-17-2008 05:36 AM
Onan Generator Problem DCTENT Alpine Coach Owner's Forum 8 09-08-2007 04:51 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.