Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 06-19-2010, 01:14 PM   #1
Junior Member
Fleetwood Owners Club
Join Date: Apr 2010
Location: Magnolia, Delaware
Posts: 26
Onan 6.5 KW (1987) Blows Fuses


I have an 88 Fleetwood Pace Arrow. Got the generator running then it just quit. Cranked one more time and thats all. Checked the fuse on the gen pannel and it was blown. Replace the fuse and as soon as I press the start button the fuse blows, every time. No crossed or touching wires, connections are clean. Any suggetions??
Terry W. is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan 6.5 emerald series gen problem bjcarpetguy MH-General Discussions & Problems 3 07-10-2009 08:01 AM
6.5 Onan Generator won't start cadteach MH-General Discussions & Problems 1 06-21-2009 11:07 PM
nhe spec-a onan 6.5 emerald III wiring problems thumbless MH-General Discussions & Problems 4 04-11-2007 12:00 AM
Jetsmania 2007 Mountain Aire Hates Warm Weather : The fan motor blows fuses Jetsmania Newmar Owner's Forum 11 01-09-2007 04:52 PM
Running lite blows fuses jcrowder47 MH-General Discussions & Problems 2 09-18-2006 11:27 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:32 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.