Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
Thread Tools Search this Thread Display Modes
Old 02-04-2010, 07:17 PM   #1
Senior Member
KIX's Avatar

Join Date: Dec 2006
Location: St. Augustine, FL
Posts: 3,579
Onan 7.5 Quiet Diesel

Our diesel generator recently started a strange problem. Sometimes it will start and run normally for several hours. Other times it will start normally and run for about 5 minutes and then shut down. When it shuts down the blink code (#24) indicates the control "board" is not getting the signal from the coolant sensor or that the coolant is not heating up. So, I have a couple of questions:

1. Where is the coolant temp sensor?
2. How would I know if it is the problem?
3. What panel(s) need to come off the gen enclosure to access?

Thanks in advance for any help.

'02 Ultimate Advantage 40J Spartan MM - Cummins ISC
2013 Jeep Rubicon JK Unlimited
KIX is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-05-2010, 01:51 AM   #2
Moderator Emeritus

Monaco Owners Club
Excel Owners Club
Join Date: Nov 2006
Location: Hangin' with Sacs and the Pins
Posts: 9,412
KIX...I have moved your thread to "MH Problems- Solutions-Aftermarket" with a three month redirect from the Winnebago forum. I am thinking you may get a bit more feedback with more of a chance from other Onan genny owners...

Good Luck finding a solution!

*MonacoMama with the 2 Pins & SacsTC Nearby*
*2007 Monaco Diplomat 40' SFT<>2006 Chevy VortecMax Toad<>2006 Buick Lucerne Leading the Way*
MonacoMama is offline   Reply With Quote
Old 02-05-2010, 03:02 AM   #3
Community Moderator
RV Wizard's Avatar

Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 11,811
The temp sensor is under the top cover panel. The whole top will have to come off and it is next to the pump. Make sure it is full of coolant. You have to access the radiator cap under the plate next to start switch. If it is full then it does sound like the temps sensor is going south.
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 02-06-2010, 12:48 AM   #4
Senior Member
SCVJeff's Avatar
Join Date: Dec 2006
Location: Santa Clarita, CA.
Posts: 2,197
Haven't had that problem with mine, but read a thread somewhere that it's somewhat sensitive to coolant levels.

Jeff - WA6EQU
'06 Itasca Meridian 34H, CAT C7/350
SCVJeff is offline   Reply With Quote
Old 02-06-2010, 04:16 PM   #5
Senior Member
KIX's Avatar

Join Date: Dec 2006
Location: St. Augustine, FL
Posts: 3,579
Thanks guys. I'll check coolant levels before I start parts changing. I'll post what I find.
'02 Ultimate Advantage 40J Spartan MM - Cummins ISC
2013 Jeep Rubicon JK Unlimited
KIX is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan 7.5 QD (Quiet Diesel) Generator GStream40 RV Systems & Appliances 11 06-15-2008 07:10 PM
7.5 Onan Diesel Generator Onthroad Fleetwood Products Owner's Forum 4 01-15-2008 05:00 PM
High dollar ONAN Quiet Diesel not worth it! Dale Tomlinson Winnebago Industries Owner's Forum 2 05-17-2005 06:24 PM
Hard starting Onan 7.5 diesel doc Winnebago Industries Owner's Forum 3 02-04-2005 08:57 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:10 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.