Go Back   iRV2 Forums > MOTORHOME FORUMS > MH-General Discussions & Problems
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-19-2012, 01:22 PM   #1
Member
 
nazoomer's Avatar
 
Join Date: Feb 2011
Posts: 57
Onan emerald II will not crank

89 driftwood with gas Onan generator. Went to cycle it last weekend, whinning sound no crank or start. Cleanded postive and ground terminals, charged batteries. Remote start does nothing, start on unit has never worked. Is there a circuit breaker or fuse somewhere? The 5 amp fuse on front of circuit board is ok via a ohm meter? any thoughts or recommendations are appreciated, thank you , Nazoomer
__________________

__________________
nazoomer is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-19-2012, 10:25 PM   #2
Member
 
Join Date: Jun 2010
Posts: 61
The whinning sound you hear is likely the starter motor whirling over without the drive gear engaging. It should engage automatically as it does not rely on a separate pull in solenoid to engage it. The most likely cause would be a bunch of teeth missing on the gear. If this is the case you will have to remove the starter to replace the gear.
__________________

__________________
Bumperfood is offline   Reply With Quote
Old 10-19-2012, 10:32 PM   #3
Member
 
nazoomer's Avatar
 
Join Date: Feb 2011
Posts: 57
Than you, today no sound or anything but do have 12 volts at board, no cranking at all.
__________________
nazoomer is offline   Reply With Quote
Old 10-20-2012, 09:11 AM   #4
Senior Member
 
DonDee's Avatar
 
Join Date: May 2012
Location: Spring Valley AZ
Posts: 1,204
Quote:
Originally Posted by nazoomer View Post
Than you, today no sound or anything but do have 12 volts at board, no cranking at all.
Mine started fine until the house batteries would suddenly not turn it over. Hit boost, fires right up. I have no doubt that one of the 6v cart batteries has pooped out. They show over 12v and run the house just fine but have no load capacity. I will have the 6v's individually load tested next week.
__________________
Don, Mary and Spooky
'00 Bluebird Skoolie Conversion
Geo Tracker/Dodge Neon/Aprilia Scooter towed
DonDee is offline   Reply With Quote
Reply

Tags
onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wiring schematic for Onan emerald 1 circuit board randrent RV Systems & Appliances 3 11-18-2011 05:54 PM
Onan Emerald III Genset No Start wiredla1 Class A Motorhome Discussions 2 06-13-2011 08:30 AM
Onan genset emerald I RonS1985 MH-General Discussions & Problems 6 09-15-2010 04:32 PM
Onan 5500 won't crank or turn over. Jerry Kraft RV Systems & Appliances 7 08-23-2010 03:47 PM
Onan Emerald Plus Service Manual? RocketDork Winnebago Industries Owner's Forum 4 03-03-2010 10:29 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:39 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.